aboutsummaryrefslogtreecommitdiffstats
path: root/testing/sbcl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/sbcl/APKBUILD')
-rw-r--r--testing/sbcl/APKBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/testing/sbcl/APKBUILD b/testing/sbcl/APKBUILD
index 113c52b1cc..e819212e03 100644
--- a/testing/sbcl/APKBUILD
+++ b/testing/sbcl/APKBUILD
@@ -17,15 +17,15 @@ source="$pkgname-$pkgver.tar.bz2::http://prdownloads.sourceforge.net/$pkgname/$p
"
builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- default_prepare
-
- cp "$srcdir"/config "$builddir"/customize-target-features.lisp
-}
-
build() {
cd "$builddir"
- GNUMAKE=make ./make.sh "clisp" --prefix=/usr
+
+ GNUMAKE=make ./make.sh clisp \
+ --prefix=/usr \
+ --without-sb-thread \
+ --without-sb-test \
+ --with-sb-unicode \
+ --with-sb-core-compression
}
package() {