aboutsummaryrefslogtreecommitdiffstats
path: root/testing/sbcl
diff options
context:
space:
mode:
Diffstat (limited to 'testing/sbcl')
-rw-r--r--testing/sbcl/APKBUILD14
-rw-r--r--testing/sbcl/config8
2 files changed, 7 insertions, 15 deletions
diff --git a/testing/sbcl/APKBUILD b/testing/sbcl/APKBUILD
index 113c52b1cc..e819212e03 100644
--- a/testing/sbcl/APKBUILD
+++ b/testing/sbcl/APKBUILD
@@ -17,15 +17,15 @@ source="$pkgname-$pkgver.tar.bz2::http://prdownloads.sourceforge.net/$pkgname/$p
"
builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- default_prepare
-
- cp "$srcdir"/config "$builddir"/customize-target-features.lisp
-}
-
build() {
cd "$builddir"
- GNUMAKE=make ./make.sh "clisp" --prefix=/usr
+
+ GNUMAKE=make ./make.sh clisp \
+ --prefix=/usr \
+ --without-sb-thread \
+ --without-sb-test \
+ --with-sb-unicode \
+ --with-sb-core-compression
}
package() {
diff --git a/testing/sbcl/config b/testing/sbcl/config
deleted file mode 100644
index e312bb72d2..0000000000
--- a/testing/sbcl/config
+++ /dev/null
@@ -1,8 +0,0 @@
-(lambda (list)
- (flet ((enable (x) (pushnew x list))
- (disable (x) (setf list (remove x list))))
- (disable :sb-thread)
- (disable :sb-test)
- (enable :sb-unicode)
- (enable :sb-core-compression))
- list)