aboutsummaryrefslogtreecommitdiffstats
path: root/testing/seamonkey/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/seamonkey/APKBUILD')
-rw-r--r--testing/seamonkey/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/testing/seamonkey/APKBUILD b/testing/seamonkey/APKBUILD
index 418e21175d..8f3eb2cb19 100644
--- a/testing/seamonkey/APKBUILD
+++ b/testing/seamonkey/APKBUILD
@@ -5,7 +5,7 @@ pkgver=2.40
pkgrel=0
pkgdesc="all-in-one internet application suite"
url="http://www.seamonkey-project.org"
-arch=""
+arch="all"
license="MPL"
depends=""
makedepends="unzip zip gtk+2.0-dev yasm alsa-lib-dev pulseaudio-dev libxt-dev
@@ -38,6 +38,8 @@ build() {
cp ../../mozconfig .mozconfig
export MOZ_MAKE_FLAGS="$MAKEFLAGS"
export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/seamonkey-$pkgver"
+ # Needed for mozilla/python/mach/mach/mixin/process.py
+ export SHELL="/bin/ash"
# Disable null pointer gcc6 optimization in gcc6 (rhbz#1328045)
MOZ_OPT_FLAGS="$MOZ_OPT_FLAGS -fno-delete-null-pointer-checks"
unset MAKEFLAGS CPPFLAGS