aboutsummaryrefslogtreecommitdiffstats
path: root/testing/sleuthkit/10_link-to-sqlite.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/sleuthkit/10_link-to-sqlite.patch')
-rw-r--r--testing/sleuthkit/10_link-to-sqlite.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/sleuthkit/10_link-to-sqlite.patch b/testing/sleuthkit/10_link-to-sqlite.patch
new file mode 100644
index 0000000000..a4de9d4630
--- /dev/null
+++ b/testing/sleuthkit/10_link-to-sqlite.patch
@@ -0,0 +1,36 @@
+From https://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/app-forensics/sleuthkit/files/sleuthkit-4.1.0-system-sqlite.patch?revision=1.1
+
+--- a/tsk/auto/db_sqlite.cpp
++++ b/tsk/auto/db_sqlite.cpp
+@@ -14,7 +14,7 @@
+ */
+
+ #include "tsk_db_sqlite.h"
+-#include "sqlite3.h"
++#include <sqlite3.h>
+
+ #include <string.h>
+
+--- a/tsk/auto/Makefile.am
++++ b/tsk/auto/Makefile.am
+@@ -3,7 +3,8 @@
+
+ noinst_LTLIBRARIES = libtskauto.la
+ # Note that the .h files are in the top-level Makefile
+-libtskauto_la_SOURCES = auto.cpp tsk_auto_i.h auto_db.cpp sqlite3.c sqlite3.h db_sqlite.cpp tsk_db_sqlite.h case_db.cpp tsk_case_db.h
++libtskauto_la_SOURCES = auto.cpp tsk_auto_i.h auto_db.cpp db_sqlite.cpp tsk_db_sqlite.h case_db.cpp tsk_case_db.h
++libtskauto_la_LIBADD = -lsqlite3
+
+ indent:
+ indent *.cpp *.h
+--- a/tsk/auto/tsk_db_sqlite.h
++++ b/tsk/auto/tsk_db_sqlite.h
+@@ -25,7 +25,7 @@
+ #include <ostream>
+
+
+-#include "sqlite3.h"
++#include <sqlite3.h>
+ #include "tsk_auto_i.h"
+
+ using std::map;