aboutsummaryrefslogtreecommitdiffstats
path: root/testing/sssd/0001-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/sssd/0001-makefile.patch')
-rw-r--r--testing/sssd/0001-makefile.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/sssd/0001-makefile.patch b/testing/sssd/0001-makefile.patch
new file mode 100644
index 0000000000..5b80e74f0b
--- /dev/null
+++ b/testing/sssd/0001-makefile.patch
@@ -0,0 +1,36 @@
+--- sssd-1.15.3/Makefile.am
++++ sssd-1.15.3-old/Makefile.am
+@@ -487,6 +487,7 @@
+ -I$(srcdir)/src/sss_client \
+ -I$(srcdir)/src \
+ -I. \
++ -I/usr/include/nspr \
+ $(POPT_CFLAGS) \
+ $(TALLOC_CFLAGS) \
+ $(TDB_CFLAGS) \
+@@ -2511,6 +2512,7 @@
+ $(POPT_LIBS) \
+ libsss_test_common.la \
+ libsss_debug.la \
++ -lintl \
+ $(NULL)
+
+ sss_nss_idmap_tests_SOURCES = \
+@@ -4053,7 +4055,8 @@
+ $(TALLOC_LIBS) \
+ $(POPT_LIBS) \
+ $(DHASH_LIBS) \
+- $(KRB5_LIBS)
++ $(KRB5_LIBS) \
++ -lintl
+
+ if BUILD_SEMANAGE
+ selinux_child_SOURCES = \
+@@ -4127,6 +4130,7 @@
+ $(POPT_LIBS) \
+ $(NSS_LIBS) \
+ libsss_crypt.la \
++ -lintl \
+ $(NULL)
+
+ memberof_la_SOURCES = \