aboutsummaryrefslogtreecommitdiffstats
path: root/testing/tarantool/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/tarantool/APKBUILD')
-rw-r--r--testing/tarantool/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/testing/tarantool/APKBUILD b/testing/tarantool/APKBUILD
index 2f7c4e2058..2c448cdf79 100644
--- a/testing/tarantool/APKBUILD
+++ b/testing/tarantool/APKBUILD
@@ -4,7 +4,7 @@
pkgname=tarantool
pkgver=1.7.4.335
_series=${pkgver%.*}; _series=${_series%.*} # x.y
-pkgrel=1
+pkgrel=2
pkgdesc="Lua application server integrated with a database management system"
url="https://tarantool.org"
arch="all !x86 !ppc64le !s390x" # bundled LuaJIT is not supported on these
@@ -54,6 +54,7 @@ build() {
-DCMAKE_C_FLAGS="$CFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc \
-DCMAKE_SKIP_RPATH=ON \
-DCMAKE_VERBOSE_MAKEFILE=ON \
-DENABLE_BUNDLED_LIBCORO=OFF \
@@ -80,7 +81,10 @@ check() {
package() {
cd "$builddir"
+
make DESTDIR="$pkgdir" install
+ rm -R "$pkgdir"/etc/default
+
install -Dm755 "$srcdir"/tarantool.initd "$pkgdir"/etc/init.d/tarantool
}