aboutsummaryrefslogtreecommitdiffstats
path: root/testing/tevent/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/tevent/APKBUILD')
-rw-r--r--testing/tevent/APKBUILD56
1 files changed, 56 insertions, 0 deletions
diff --git a/testing/tevent/APKBUILD b/testing/tevent/APKBUILD
new file mode 100644
index 0000000000..17bfa65935
--- /dev/null
+++ b/testing/tevent/APKBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=tevent
+pkgver=0.9.18
+pkgrel=0
+pkgdesc="The tevent library"
+url="http://tevent.samba.org/"
+arch="all"
+license="LGPLv3+"
+depends=""
+depends_dev=""
+makedepends="$depends_dev python-dev"
+install=""
+subpackages="$pkgname-dev py-$pkgname:_py"
+source="http://samba.org/ftp/tevent/tevent-$pkgver.tar.gz"
+
+_builddir="$srcdir"/tevent-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-rpath \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+_py() {
+ pkgdesc="Python binding for the tevent library"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+}
+
+md5sums="952535f0bcf002eee5a8db68deb6374b tevent-0.9.18.tar.gz"
+sha256sums="5c636a0c55a7b59745bae0d8ae3900b5ea8c09bfff6001dcd95f1db9cd06ea4f tevent-0.9.18.tar.gz"
+sha512sums="b95c3c28dd484741c6d5ab18b28f9ae144026876bccfa2345fdf75b5601f589f1e9cca392390dd0056e4a60271a22c9b7798db2c5d7a2f8c9cba5d258bd3e9af tevent-0.9.18.tar.gz"