aboutsummaryrefslogtreecommitdiffstats
path: root/testing/time/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/time/APKBUILD')
-rw-r--r--testing/time/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/time/APKBUILD b/testing/time/APKBUILD
new file mode 100644
index 0000000000..5ec2845cdf
--- /dev/null
+++ b/testing/time/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Sascha Paunovic <azarus@posteo.net>
+# Maintainer: Sascha Paunovic <azarus@posteo.net>
+pkgname=time
+pkgver=1.9
+pkgrel=0
+pkgdesc="utility to measure execution time"
+url="https://www.gnu.org/software/time/"
+arch="all"
+license="GPL-3.0-only"
+subpackages="$pkgname-doc"
+source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="5c6dabbbe71e9103a47b892b86bb914c1704122d4fe7dff1e2cbd28503297163118d295077d8e062b035d673a1f91c36f8a45c7383f374fd766942b32bde4406 time-1.9.tar.gz"