aboutsummaryrefslogtreecommitdiffstats
path: root/testing/tmate/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/tmate/APKBUILD')
-rw-r--r--testing/tmate/APKBUILD23
1 files changed, 8 insertions, 15 deletions
diff --git a/testing/tmate/APKBUILD b/testing/tmate/APKBUILD
index 8ced6a7519..17ced9fb14 100644
--- a/testing/tmate/APKBUILD
+++ b/testing/tmate/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Isaksen <d@duniel.no>
pkgname=tmate
-pkgver=2.2.1
-pkgrel=2
+pkgver=2.3.1
+pkgrel=0
pkgdesc="Instant Terminal Sharing"
url="https://tmate.io/"
arch="all"
@@ -9,19 +9,15 @@ license="ISC"
depends="ncurses-terminfo"
makedepends="ncurses-dev libevent-dev autoconf automake bsd-compat-headers
libtool zlib-dev libssh-dev msgpack-c-dev"
-install=
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/$pkgname-io/$pkgname/archive/$pkgver.tar.gz
- 0001-Fix-building-with-or-without-backtrace-3.patch
- "
-
-builddir="$srcdir/"$pkgname-$pkgver
-
-build() {
- cd "$builddir"
+source="tmate-$pkgver.tar.gz::https://github.com/tmate-io/tmate/archive/$pkgver.tar.gz"
+prepare() {
+ default_prepare
./autogen.sh
+}
+build() {
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -33,12 +29,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -Dm644 example_tmux.conf \
@@ -48,5 +42,4 @@ package() {
done
}
-sha512sums="3d4ce7510cd8da39bc4fe63f2a64179846a813bb3560ca811d9e1e2a28b06d95a9033047a900d76bda069c249d7ebbe1143daa082b23212c5d32a50bf1819d2d tmate-2.2.1.tar.gz
-e530890d9771af22f99b6903bd37690a6cb58a3df8950dfc2159f383ed286541e12beeedd0d9752e3830799a43d12cf4f742ab64807aeef966c40ef556d9ed87 0001-Fix-building-with-or-without-backtrace-3.patch"
+sha512sums="98531e3a3c1cc4da11894e8298df560fd58f1ede6a81ac8cb5f8cbea86f5c21672a016977dab801ec06e14f6c718a64599a9e32740934fcd4c0a155f92710520 tmate-2.3.1.tar.gz"