aboutsummaryrefslogtreecommitdiffstats
path: root/testing/tmate/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/tmate/APKBUILD')
-rw-r--r--testing/tmate/APKBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/testing/tmate/APKBUILD b/testing/tmate/APKBUILD
index 82e4bdf021..fc9e7ddd12 100644
--- a/testing/tmate/APKBUILD
+++ b/testing/tmate/APKBUILD
@@ -1,25 +1,26 @@
# Maintainer: Daniel Isaksen <d@duniel.no>
pkgname=tmate
pkgver=2.2.1
-pkgrel=0
+pkgrel=1
pkgdesc="Instant Terminal Sharing"
url="https://tmate.io/"
arch="all"
license="ISC"
depends="ncurses-terminfo"
makedepends="ncurses-dev libevent-dev autoconf automake bsd-compat-headers
- libtool zlib-dev libssh-dev msgpack-c-dev libexecinfo-dev"
+ libtool zlib-dev libssh-dev msgpack-c-dev"
install=
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/$pkgname-io/$pkgname/archive/$pkgver.tar.gz
- remove-backtrace-musl.patch"
+ 0001-Fix-building-with-or-without-backtrace-3.patch
+ "
builddir="$srcdir/"$pkgname-$pkgver
build() {
cd "$builddir"
- ./autogen.sh || return 1
+ ./autogen.sh
./configure \
--build=$CBUILD \
@@ -48,4 +49,4 @@ package() {
}
sha512sums="3d4ce7510cd8da39bc4fe63f2a64179846a813bb3560ca811d9e1e2a28b06d95a9033047a900d76bda069c249d7ebbe1143daa082b23212c5d32a50bf1819d2d tmate-2.2.1.tar.gz
-530f17f86688980fb3e0d48adaff70cc413efafda7025be4f1dfaaf5a3d71ab21ee923a1d658d30691464e375aea73ba1b06a4b5545998c4a7df9dc19fc91561 remove-backtrace-musl.patch"
+e530890d9771af22f99b6903bd37690a6cb58a3df8950dfc2159f383ed286541e12beeedd0d9752e3830799a43d12cf4f742ab64807aeef966c40ef556d9ed87 0001-Fix-building-with-or-without-backtrace-3.patch"