aboutsummaryrefslogtreecommitdiffstats
path: root/testing/tolua/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/tolua/APKBUILD')
-rw-r--r--testing/tolua/APKBUILD46
1 files changed, 0 insertions, 46 deletions
diff --git a/testing/tolua/APKBUILD b/testing/tolua/APKBUILD
deleted file mode 100644
index b7349f6812..0000000000
--- a/testing/tolua/APKBUILD
+++ /dev/null
@@ -1,46 +0,0 @@
-# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=tolua
-pkgver=5.1.4
-pkgrel=0
-pkgdesc="Tool to integrace C/C++ code in lua"
-url="http://www.tecgraf.puc-rio.br/~celes/tolua/"
-arch="all"
-license="MIT"
-depends=""
-depends_dev="lua-dev"
-makedepends="$depends_dev"
-install=""
-subpackages="$pkgname-dev"
-source="http://www.tecgraf.puc-rio.br/~celes/tolua/tolua-$pkgver.tar.gz"
-
-_builddir="$srcdir"/tolua-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
- sed -i -e '/^CC=/d' \
- -e 's/^CCPP *=.*/CCPP=$(CXX)/' \
- -e 's/^CFLAGS *=/CFLAGS+=/' \
- -e 's/^CPPFLAGS *=/CPPFLAGS+=/' \
- config || return 1
- # clean up some stuff that probably not was supposed to be there
- find \( -name '.*DS_Store' -o -name '._*' \) -delete
-}
-
-build() {
- cd "$_builddir"
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- install -d "$pkgdir"/usr
- cp -r bin lib include "$pkgdir"/usr/
-}
-
-md5sums="46d67c3b9b4b983368a9ff0baa2139f9 tolua-5.1.4.tar.gz"