aboutsummaryrefslogtreecommitdiffstats
path: root/testing/tslib
diff options
context:
space:
mode:
Diffstat (limited to 'testing/tslib')
-rw-r--r--testing/tslib/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/tslib/APKBUILD b/testing/tslib/APKBUILD
new file mode 100644
index 0000000000..353fb5f4fb
--- /dev/null
+++ b/testing/tslib/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Clayton Craft <clayton@craftyguy.net>
+# Maintainer: Clayton Craft <clayton@craftyguy.net>
+pkgname=tslib
+pkgver=1.13
+pkgrel=0
+pkgdesc="Touchscreen Access Library"
+arch="all"
+url="https://github.com/kergoth/tslib"
+license="LGPL2+"
+makedepends="autoconf automake libtool linux-headers"
+source="https://github.com/kergoth/tslib/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc"
+builddir="${srcdir}/${pkgname}-${pkgver}"
+
+build() {
+ ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+check() {
+ cd "${builddir}"
+ make check
+}
+
+package() {
+ cd "${builddir}"
+ make DESTDIR="${pkgdir}" install
+}
+sha512sums="d96756576f2ffbc075bbe450a7a616cea9b0de97ef6ccb7868a237e7da6855af3eb47e13afd1ad4d82cf165628d5c3c45def7e07ae606a561bee5e7445cf5366 tslib-1.13.tar.xz"