aboutsummaryrefslogtreecommitdiffstats
path: root/testing/tsung/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/tsung/APKBUILD')
-rw-r--r--testing/tsung/APKBUILD60
1 files changed, 60 insertions, 0 deletions
diff --git a/testing/tsung/APKBUILD b/testing/tsung/APKBUILD
new file mode 100644
index 0000000000..7041953948
--- /dev/null
+++ b/testing/tsung/APKBUILD
@@ -0,0 +1,60 @@
+# Contributor: Michael Truog <mjtruog@gmail.com>
+# Maintainer: Michael Truog <mjtruog@gmail.com>
+
+pkgname=tsung
+pkgver=1.6.0.1
+_srcver=445d78213bb4360d78df3753b3e23e6a28d701f0
+pkgrel=0
+pkgdesc="Tsung is a high-performance benchmark framework for various protocols including HTTP,XMPP,LDAP,etc."
+url="http://www.process-one.net/en/tsung/"
+license="GPL2"
+arch="noarch"
+depends="bash
+ erlang
+ gnuplot
+ perl-template-toolkit
+ python2
+ py-matplotlib
+ "
+makedepends="erlang
+ erlang-asn1
+ erlang-crypto
+ erlang-dev
+ erlang-eunit
+ erlang-inets
+ erlang-os-mon
+ erlang-snmp
+ erlang-ssl
+ erlang-tools
+ erlang-xmerl
+ perl
+ "
+subpackages=""
+source="https://github.com/processone/$pkgname/archive/$_srcver.tar.gz
+ 0005-Do-not-install-manpages-in-main-install.patch"
+
+builddir="$srcdir/tsung-$_srcver"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host="$CHOST" \
+ --build="$CBUILD"
+ make -j1
+}
+
+check() {
+ cd "$builddir"
+ make -j1 test
+}
+
+package() {
+ cd "$builddir"
+ make -j1 DESTDIR="$pkgdir" install
+}
+
+sha512sums="53a16363d30c2b593d4b3cda789457cd00f009c4163924a01d6a1b08f725cde2be35d02902a3c8436ddc5db7fb6215384444609c354c171ca4cf0088418f7934 445d78213bb4360d78df3753b3e23e6a28d701f0.tar.gz
+ee80c21fe6a66c96b1aa68afd96209516a5a3fe1d51a1ee01a1f465d164c332bbe30f03de1cc20f3d6e0651770fa7e579d64f52d282b64d6ca02d098852f2a93 0005-Do-not-install-manpages-in-main-install.patch"