aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ucl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/ucl/APKBUILD')
-rw-r--r--testing/ucl/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/ucl/APKBUILD b/testing/ucl/APKBUILD
new file mode 100644
index 0000000000..096d3e8851
--- /dev/null
+++ b/testing/ucl/APKBUILD
@@ -0,0 +1,31 @@
+#-*-mode: Shell-script; coding: utf-8;-*-
+# Maintainer: Mitch Tishmack <mitch.tishmack@gmail.com>
+pkgname=ucl
+pkgver=1.03
+pkgrel=0
+pkgdesc="Portable lossless data compression library written in ANSI C"
+url="http://www.oberhumer.com/opensource/ucl/"
+arch="all"
+license="gpl"
+makedepends="file"
+source="
+ http://www.oberhumer.com/opensource/$pkgname/download/$pkgname-$pkgver.tar.gz
+ 0001-Static-assert.patch
+"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr --enable-shared --enable-static || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="852bd691d8abc75b52053465846fba34 ucl-1.03.tar.gz
+e852ab6af348477e6c6b3f1ee41b2200 0001-Static-assert.patch"
+sha256sums="b865299ffd45d73412293369c9754b07637680e5c826915f097577cd27350348 ucl-1.03.tar.gz
+b0269e9f934e23a5992acffe193a27892cd47d91a7e0d65cb6a91e2131896a65 0001-Static-assert.patch"
+sha512sums="7dd1824d01b4bb41ee03bbceddc634a9f7f910d235e5cca163d783680d6743f0f3cc309bbbcc1e094d897d549d3805a555f9093b4d77805443d896dd1862aa34 ucl-1.03.tar.gz
+24a34de871fcfa919985afc29c60496b1f0e730550e8387f212a5229f32ccade4178d1221574d86c36d025c08b3b5ed6d236f2b4d740436afe0451ae9050f890 0001-Static-assert.patch"