aboutsummaryrefslogtreecommitdiffstats
path: root/testing/util-vserver/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/util-vserver/APKBUILD')
-rw-r--r--testing/util-vserver/APKBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/testing/util-vserver/APKBUILD b/testing/util-vserver/APKBUILD
index db7d785b2b..4d70b9f81d 100644
--- a/testing/util-vserver/APKBUILD
+++ b/testing/util-vserver/APKBUILD
@@ -2,7 +2,7 @@
pkgname=util-vserver
pkgver=0.30.216_pre2849
_realver=0.30.216-pre2849
-pkgrel=1
+pkgrel=2
pkgdesc="Linux-VServer admin utilities"
url="http://www.nongnu.org/util-vserver/"
license="GPL"
@@ -24,9 +24,12 @@ subpackages="$pkgname-doc $pkgname-dev"
build() {
local i
cd "$srcdir"/$pkgname-$_realver
- patch -p1 -i ../chmod.patch || return 1
- patch -p1 -i ../ensc_pathprog.patch || return 1
- patch -p1 -i ../validate.patch || return 1
+ for i in ../*.patch; do
+ [ -r "$i" ] || continue
+ msg "Applying $i"
+ patch -p1 -i $i || return 1
+ done
+ msg "Running autotools..."
aclocal -I m4 && autoconf && automake && libtoolize || return 1
# this is an ugly workaround
@@ -39,6 +42,8 @@ build() {
--localstatedir=/var \
|| return 1
+ # use busybox ionice rather than util-linux-ng
+ sed -i -e 's:/usr/bin/ionice:/bin/ionice:' Makefile
make || return 1
make DESTDIR="$pkgdir/" install install-distribution
install -Dm755 ../setup-vs-template "$pkgdir"/usr/sbin/setup-vs-template
@@ -50,5 +55,5 @@ md5sums="af4c22b420320bdd94a1756f3c90de20 util-vserver-0.30.216-pre2849.tar.bz2
ff8f561f672524eb46fe633f584ef60e ensc_pathprog.patch
da8b70c4fd40e68894b3903ffd121397 validate.patch
04000261fd990a3963b0e98260b481bd alpine.patch
-4504f4a97eba4a4ab21feff1b121c7bd setup-vs-template
+49bca7969cc284adf68e0ef284c0660e setup-vs-template
b7a30afd4ba87968cb58137d59d8e8f8 setup-vs-guest"