aboutsummaryrefslogtreecommitdiffstats
path: root/testing/virtualbox-additions-hardened
diff options
context:
space:
mode:
Diffstat (limited to 'testing/virtualbox-additions-hardened')
-rw-r--r--testing/virtualbox-additions-hardened/APKBUILD70
-rw-r--r--testing/virtualbox-additions-hardened/virtualbox-modules-4.1.4-pax-const.patch48
2 files changed, 0 insertions, 118 deletions
diff --git a/testing/virtualbox-additions-hardened/APKBUILD b/testing/virtualbox-additions-hardened/APKBUILD
deleted file mode 100644
index 9e3f834538..0000000000
--- a/testing/virtualbox-additions-hardened/APKBUILD
+++ /dev/null
@@ -1,70 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-
-_flavor=hardened
-_kpkg=linux-$_flavor
-_kver=4.9.73
-_kpkgrel=0
-
-# when chaning _ver we *must* bump _mypkgrel
-_ver=5.1.26
-_mypkgrel=0
-_name=virtualbox-additions
-
-
-_kpkgver="$_kver-r$_kpkgrel"
-_abi_release=${_kver}-${_kpkgrel}-${_flavor}
-
-pkgname=${_name}-${_flavor}
-pkgver=$_kver
-pkgrel=$(($_kpkgrel + $_mypkgrel))
-pkgdesc="Virtual box additions kernel modules for $_flavor"
-arch="x86 x86_64"
-url='http://virtualbox.org'
-license="GPL custom"
-depends="${_kpkg}=${_kpkgver}"
-makedepends="linux-${_flavor}-dev"
-provides="${_name}-grsec=${pkgver}-r${pkgrel}"
-source="http://dev.gentoo.org/~polynomial-c/virtualbox/vbox-kernel-module-src-$_ver.tar.xz
- virtualbox-modules-4.1.4-pax-const.patch
- "
-
-builddir="$srcdir"/
-
-prepare() {
- # verify the kernel version
- (
- _kapkbuild="$startdir"/../../main/linux-${_flavor}/APKBUILD
- if [ -f $_kapkbuild ]; then
- . $_kapkbuild
- pkgname=$_name-$_flavor
- if [ "$_kver" != "$pkgver" ]; then
- die "please update _kver to $pkgver"
- fi
- if [ "$_kpkgrel" != "$pkgrel" ]; then
- die "please update _kpkgrel to $pkgrel"
- fi
- fi
- ) || return 1
-
- cd "$builddir"
- default_prepare || return 1
-}
-
-build() {
- cd "$builddir"
- export KERN_DIR=/usr/src/linux-headers-${_abi_release}
- make
-}
-
-package() {
- local module=
- cd "$builddir"
- for module in *.ko; do
- install -D -m644 $module \
- "$pkgdir/lib/modules/${_abi_release}/misc/$module" \
- || return 1
- done
-}
-
-sha512sums="c77e0d8dfade2abac95162e7e7a424be4875e44d43bcf2a13e0e50caa69f5fd0d21c77f03bb2cd4cbd5df4ab31e9fbd49ecd9220a49af8cd10081b960e014010 vbox-kernel-module-src-5.1.26.tar.xz
-9a9a982defed6d4453bc6d9388c3a71169bba85568cfd36d0d2588dda8e213a0d759c983a337a150d17c55bb6206e43738dfd2559fedeb85e132363936a48574 virtualbox-modules-4.1.4-pax-const.patch"
diff --git a/testing/virtualbox-additions-hardened/virtualbox-modules-4.1.4-pax-const.patch b/testing/virtualbox-additions-hardened/virtualbox-modules-4.1.4-pax-const.patch
deleted file mode 100644
index 5e89ab43c8..0000000000
--- a/testing/virtualbox-additions-hardened/virtualbox-modules-4.1.4-pax-const.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-diff -urp vboxdrv.orig/SUPDrvIDC.h vboxdrv/SUPDrvIDC.h
---- a/vboxdrv.orig/SUPDrvIDC.h 2011-09-06 15:53:27.852567531 +0200
-+++ b/vboxdrv/SUPDrvIDC.h 2011-09-06 15:54:05.420565524 +0200
-@@ -160,7 +160,7 @@ typedef struct SUPDRVIDCREQGETSYM
- {
- /** The symbol address. */
- PFNRT pfnSymbol;
-- } Out;
-+ } __no_const Out;
- } u;
- } SUPDRVIDCREQGETSYM;
- /** Pointer to a SUPDRV IDC get symbol request. */
-diff -urp vboxnetflt.orig/include/VBox/intnet.h vboxnetflt/include/VBox/intnet.h
---- a/vboxnetflt.orig/include/VBox/intnet.h 2011-09-06 15:53:27.852567531 +0200
-+++ b/vboxnetflt/include/VBox/intnet.h 2011-09-06 15:54:05.424565524 +0200
-@@ -783,7 +783,7 @@ typedef struct INTNETTRUNKFACTORY
- DECLR0CALLBACKMEMBER(int, pfnCreateAndConnect,(struct INTNETTRUNKFACTORY *pIfFactory, const char *pszName,
- PINTNETTRUNKSWPORT pSwitchPort, uint32_t fFlags,
- PINTNETTRUNKIFPORT *ppIfPort));
--} INTNETTRUNKFACTORY;
-+} __no_const INTNETTRUNKFACTORY;
- /** Pointer to the trunk factory. */
- typedef INTNETTRUNKFACTORY *PINTNETTRUNKFACTORY;
-
-diff -urp vboxnetflt.orig/linux/VBoxNetFlt-linux.c vboxnetflt/linux/VBoxNetFlt-linux.c
---- a/vboxnetflt.orig/linux/VBoxNetFlt-linux.c 2011-07-19 12:15:22.000000000 +0200
-+++ b/vboxnetflt/linux/VBoxNetFlt-linux.c 2011-09-06 15:56:00.516559379 +0200
-@@ -840,7 +840,7 @@ typedef struct ethtool_ops OVR_OPSTYPE;
-
- # else /* LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 29) */
-
--typedef struct net_device_ops OVR_OPSTYPE;
-+typedef net_device_ops_no_const OVR_OPSTYPE;
- # define OVR_OPS netdev_ops
- # define OVR_XMIT pOrgOps->ndo_start_xmit
-
-diff -urp vboxpci.orig/include/VBox/rawpci.h vboxpci/include/VBox/rawpci.h
---- a/vboxpci.orig/include/VBox/rawpci.h 2011-04-18 17:01:12.000000000 +0200
-+++ b/vboxpci/include/VBox/rawpci.h 2011-09-06 15:57:17.340555277 +0200
-@@ -545,7 +545,7 @@ typedef struct RAWPCIFACTORY
- DECLR0CALLBACKMEMBER(void, pfnDeinitVm,(PRAWPCIFACTORY pFactory,
- PVM pVM,
- PRAWPCIPERVM pPciData));
--} RAWPCIFACTORY;
-+} __no_const RAWPCIFACTORY;
-
- #define RAWPCIFACTORY_UUID_STR "ea089839-4171-476f-adfb-9e7ab1cbd0fb"
-