aboutsummaryrefslogtreecommitdiffstats
path: root/testing/vlc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/vlc/APKBUILD')
-rw-r--r--testing/vlc/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/testing/vlc/APKBUILD b/testing/vlc/APKBUILD
index 22b1de77ee..09d301181c 100644
--- a/testing/vlc/APKBUILD
+++ b/testing/vlc/APKBUILD
@@ -97,7 +97,9 @@ build ()
cd "$_builddir"
sed -i -e 's:/usr/share/fonts/truetype/freefont/FreeSerifBold.ttf:/usr/share/fonts/TTF/DejaVuSerif-Bold.ttf:' modules/misc/freetype.c
- export CFLAGS="$CFLAGS -D_GNU_SOURCE"
+ # -fpermissive is needed due to zlib 1.2.6 changing
+ # void* to gzFile on gz*() functions
+ export CFLAGS="$CFLAGS -D_GNU_SOURCE -fpermissive"
./configure --prefix=/usr \
--disable-mmx \