aboutsummaryrefslogtreecommitdiffstats
path: root/testing/wayfire
diff options
context:
space:
mode:
Diffstat (limited to 'testing/wayfire')
-rw-r--r--testing/wayfire/APKBUILD22
-rw-r--r--testing/wayfire/wlroots.patch11
2 files changed, 12 insertions, 21 deletions
diff --git a/testing/wayfire/APKBUILD b/testing/wayfire/APKBUILD
index 38332d4c2e..0aa8baff25 100644
--- a/testing/wayfire/APKBUILD
+++ b/testing/wayfire/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Danct12 <danct12@disroot.org>
# Maintainer: Danct12 <danct12@disroot.org>
pkgname=wayfire
-pkgver=0.3.1
-pkgrel=1
+pkgver=0.4.0
+pkgrel=0
pkgdesc="Compiz-clone Wayland compositor"
url="https://wayfire.org"
arch="all"
@@ -15,23 +15,25 @@ makedepends="
wf-config-dev
cairo-dev
libexecinfo-dev
+ libxml2-dev
"
options="!check" # no testsuite
subpackages="$pkgname-dev"
-source="https://github.com/WayfireWM/wayfire/releases/download/$pkgver/wayfire-$pkgver.tar.xz
- wlroots.patch
- "
+source="https://github.com/WayfireWM/wayfire/releases/download/$pkgver/wayfire-$pkgver.tar.xz"
build() {
- meson build --prefix=/usr --buildtype=plain
+ meson build \
+ --prefix=/usr \
+ --buildtype=plain \
+ -Duse_system_wlroots=enabled \
+ -Duse_system_wfconfig=enabled
}
package() {
DESTDIR="$pkgdir" ninja -C build install
- install -Dm644 "$builddir/wayfire.ini.default" "$pkgdir/usr/share/wayfire/wayfire.ini.default"
- install -Dm644 "$builddir/wayfire.desktop" "$pkgdir/usr/share/wayland-sessions/wayfire.desktop"
+ install -Dm644 wayfire.ini "$pkgdir"/usr/share/wayfire/wayfire.ini.default
+ install -Dm644 wayfire.desktop "$pkgdir"/usr/share/wayland-sessions/wayfire.desktop
}
-sha512sums="a64ffd15a624202951fb4245a300c5346b54b08905d31441b351888380aa44037f4fffd30330b81b3eeba893cfb558f2c2bc761be510dc7c5e21fd181033f0df wayfire-0.3.1.tar.xz
-15e6dd683afdc3cec31cd3bbef74587e7bf64c0d6a291ba28ae82acb2ccf11504592f5823fbd7031586aa16564070af126b4dc666cb77c2644ab89c3a28e8c36 wlroots.patch"
+sha512sums="e96cdb90ce36c005476e08608683983aa167e58aea80fcfd3b24ab0836ec4aa50fb5a7eeb0872a1b1014e3073ed826e1c83d3146b39d3cdb2a8b3a0895155649 wayfire-0.4.0.tar.xz"
diff --git a/testing/wayfire/wlroots.patch b/testing/wayfire/wlroots.patch
deleted file mode 100644
index e7ae792415..0000000000
--- a/testing/wayfire/wlroots.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/meson.build 2020-01-30 18:00:20.201729274 +0200
-+++ b/meson.build 2020-01-30 17:58:28.720588270 +0200
-@@ -29,7 +29,7 @@
- pixman = dependency('pixman-1')
- threads = dependency('threads')
- xkbcommon = dependency('xkbcommon')
--wlroots = dependency('wlroots', version: ['>=0.9.0', '<0.10.0'], fallback: ['wlroots', 'wlroots'])
-+wlroots = dependency('wlroots', version: ['>=0.9.0', '<0.11.0'], fallback: ['wlroots', 'wlroots'])
- wfconfig = dependency('wf-config', version: '>=0.3', fallback: ['wf-config', 'wfconfig'])
-
- needs_libinotify = ['freebsd', 'dragonfly'].contains(host_machine.system())