aboutsummaryrefslogtreecommitdiffstats
path: root/testing/wireguard-vanilla
diff options
context:
space:
mode:
Diffstat (limited to 'testing/wireguard-vanilla')
-rw-r--r--testing/wireguard-vanilla/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/testing/wireguard-vanilla/APKBUILD b/testing/wireguard-vanilla/APKBUILD
index f1c026e140..7a9807063c 100644
--- a/testing/wireguard-vanilla/APKBUILD
+++ b/testing/wireguard-vanilla/APKBUILD
@@ -7,8 +7,10 @@ _kver=4.9.28
_kpkgrel=1
# when changing _ver we *must* bump _mypkgrel
+# we must also match up _toolsrel with wireguard-tools
_ver=0.0.20170517
-_mypkgrel=0
+_mypkgrel=1
+_toolsrel=0
_name=wireguard
# verify the kernel version before entering chroot
@@ -21,6 +23,7 @@ if [ -f $_kapkbuild ]; then
fi
_kpkgver="$_kver-r$_kpkgrel"
+_toolsver="$_ver-r$toolsrel"
_abi_release=${_kver}
pkgname=${_name}-${_flavor}
@@ -32,7 +35,7 @@ url='https://www.wireguard.io'
license="GPLv2"
depends="${_kpkg}=${_kpkgver}"
makedepends="linux-vanilla-dev=$_kpkgver libmnl-dev"
-install_if="wireguard-tools linux-vanilla-$_kpkgver"
+install_if="wireguard-tools=$_toolsver linux-vanilla=$_kpkgver"
options="!check"
source="https://git.zx2c4.com/WireGuard/snapshot/WireGuard-$_ver.tar.xz"
builddir="$srcdir"/WireGuard-$_ver