aboutsummaryrefslogtreecommitdiffstats
path: root/testing/wput/wput-destdir.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/wput/wput-destdir.patch')
-rw-r--r--testing/wput/wput-destdir.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/wput/wput-destdir.patch b/testing/wput/wput-destdir.patch
new file mode 100644
index 0000000000..1098ceef8d
--- /dev/null
+++ b/testing/wput/wput-destdir.patch
@@ -0,0 +1,37 @@
+--- wput-0.6.2/Makefile.in
++++ wput-0.6.2/Makefile.in.new
+@@ -4,7 +4,7 @@
+ datadir = $(prefix)/share
+ mandir = $(datadir)/man/man1
+ exec_prefix = @exec_prefix@
+-bindir=@bindir@
++bindir = @bindir@
+
+ all clean:
+ cd po && $(MAKE) $(MAKEDEFS) $@
+@@ -16,20 +16,11 @@
+
+ install: all
+ cd po && $(MAKE) $(MAKEDEFS) $@
+- mkdir -p $(bindir)
+- mkdir -p $(mandir)
+- install -m0755 wput $(bindir)
+- install -m0644 doc/wput.1.gz $(mandir)
+- ln -s $(bindir)/wput $(bindir)/wdel
+- install -m0644 doc/wdel.1.gz $(mandir)
+- @echo "----------------"
+- @echo "Wput and Wdel installed. See 'wput/wdel -h' or 'man wput/wdel' for"
+- @echo "usage information."
+- @echo "Further documentation is located in the doc/USAGE.* files."
+- @echo
+- @echo "Wput is not perfect, so please report any bugs you notice (see BUGS-section"
+- @echo "in the manpage)."
+- @echo "----------------"
++ install -D -p -m 0755 wput $(DESTDIR)$(bindir)/wput
++ install -D -p -m 0644 doc/wput.1.gz $(DESTDIR)$(mandir)/wput.1.gz
++ ln -s $(DESTDIR)$(bindir)/wput $(DESTDIR)$(bindir)/wdel
++ install -D -p -m 0644 doc/wdel.1.gz $(DESTDIR)$(mandir)/wdel.1.gz
++
+ uninstall:
+ rm -f $(bindir)/wput
+ rm -f $(bindir)/wdel