aboutsummaryrefslogtreecommitdiffstats
path: root/testing/wt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/wt/APKBUILD')
-rw-r--r--testing/wt/APKBUILD61
1 files changed, 61 insertions, 0 deletions
diff --git a/testing/wt/APKBUILD b/testing/wt/APKBUILD
new file mode 100644
index 0000000000..e0916c68b4
--- /dev/null
+++ b/testing/wt/APKBUILD
@@ -0,0 +1,61 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=wt
+pkgver=3.3.4
+_pkgver=3.3.4
+pkgrel=0
+pkgdesc="A C++ library and application server for developing and deploying web applications"
+url="http://www.webtoolkit.eu"
+arch="all"
+license="GPL"
+depends=""
+depends_dev="zlib-dev boost-dev sqlite-dev mesa-dev glu-dev graphicsmagick-dev
+ openssl-dev pango-dev sqlite-dev fcgi-dev postgresql-dev qt-dev libharu-dev"
+makedepends="$depends_dev cmake boost"
+install=""
+pkgroups="wt"
+pkgusers="wt"
+subpackages="$pkgname-dev"
+source="http://downloads.sourceforge.net/witty/$pkgname-${_pkgver}.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ mkdir -p build && cd build
+ cmake \
+ -DCONNECTOR_HTTP=ON \
+ -DWT_CPP_11_MODE=-std=c++11 \
+ -DWT_WRASTERIMAGE_IMPLEMENTATION=GraphicsMagick \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DWEBUSER=$pkgusers \
+ -DWEBGROUP=$pkggroups \
+ -DRUNDIR="$pkgdir"/var/run/wt \
+ -DUSE_SYSTEM_SQLITE3=ON \
+ -DINSTALL_EXAMPLES=ON \
+ -DBUILD_EXAMPLES=OFF \
+ -DINSTALL_FINDWT_CMAKE_FILE=ON \
+ ..
+ make || return 1
+
+}
+
+package() {
+ cd "$_builddir"/build
+ make DESTDIR=$pkgdir install
+ rm -r $pkgdir/usr/cmake
+ rm -rf $pkgdir/var/run
+}
+
+md5sums="fdbb6042c7d6901e254685966ff55fac wt-3.3.4.tar.gz"
+sha256sums="327f9c64504366e3f2fa2c8f1d1a23efc7b8fba8ace3869de375d668f99ede10 wt-3.3.4.tar.gz"
+sha512sums="1deff3fe325b8e009713bcbc388058d025864b3724bf1cf1cb3c36e909520046189d4a13de0adbff5c11d171536819b687d598d125b4041dd78bb4a3c5a6c279 wt-3.3.4.tar.gz"