aboutsummaryrefslogtreecommitdiffstats
path: root/testing/xen/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/xen/APKBUILD')
-rw-r--r--testing/xen/APKBUILD77
1 files changed, 0 insertions, 77 deletions
diff --git a/testing/xen/APKBUILD b/testing/xen/APKBUILD
deleted file mode 100644
index c3ff291ae2..0000000000
--- a/testing/xen/APKBUILD
+++ /dev/null
@@ -1,77 +0,0 @@
-# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: William Pitcock <nenolod@dereferenced.org>
-pkgname=xen
-pkgver=4.0.1
-pkgrel=2
-pkgdesc="Xen hypervisor"
-url="http://www.xen.org/"
-license="GPL"
-depends="coreutils python sed gawk"
-makedepends="libgcrypt-dev gnutls-dev pciutils-dev texinfo wget mesa-dev sdl-dev zlib-dev openssl-dev util-linux-ng-dev python-dev gettext-dev ncurses-dev"
-install=
-subpackages="$pkgname-doc"
-source="http://bits.xensource.com/oss-xen/release/$pkgver/$pkgname-$pkgver.tar.gz
- xen-blktap-uclibc.patch
- xen-blktap2-uclibc.patch
- xen-disable-firmware.patch
- xen-disable-fsback.patch
- xen-disable-werror.patch
- xen-dont-use-lib64.patch
- xend.initd
- xendomains.initd"
-arch="x86_64"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- cd "$_builddir"
-
- for i in $source; do
- case $i in
- *.patch)
- msg "Applying $i..."
- patch -s -p1 -N -i "$srcdir"/$i || return 1
- ;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
-
- # We unset $CFLAGS and $LDFLAGS because Xen's buildsystem does not
- # like these values being set. Arguably this is a bug but I can't be
- # bothered to track it down. --nenolod
- unset CFLAGS
- unset LDFLAGS
-
- # If we provide no parameters it tries to build a kernel image. We
- # definitely don't want that.
- (cd tools/check; ./chk build) || return 1
- make -j1 xen tools stubdom || return 1
-}
-
-package() {
- cd "$_builddir"
-
- # We unset $CFLAGS and $LDFLAGS because Xen's buildsystem does not
- # like these values being set. Arguably this is a bug but I can't be
- # bothered to track it down. --nenolod
- unset CFLAGS
- unset LDFLAGS
-
- make DESTDIR="$pkgdir" install-xen install-tools install-stubdom
-
- install -m755 -D "$srcdir"/xend.initd "$pkgdir"/etc/init.d/xend
- install -m755 -D "$srcdir"/xendomains.initd "$pkgdir"/etc/init.d/xendomains
-}
-
-md5sums="d197afad975ab2396a67323d57388c27 xen-4.0.1.tar.gz
-edb5c3e7fba8214702fac709f0e53124 xen-blktap-uclibc.patch
-1f7f847ae0baa915c7b52d0ed5869fe6 xen-blktap2-uclibc.patch
-a569f16a7e3c832ba3fab6154f657244 xen-disable-firmware.patch
-03d1fff892e627b812bba4e6c56d696a xen-disable-fsback.patch
-949d0d3bc1e8f300a849279b60760c6a xen-disable-werror.patch
-b6599060e22b61dabee0fe460b4a0c9d xen-dont-use-lib64.patch
-1d81b04f8c8b919879a73f0e3d2fe80f xend.initd
-a2b5234483f1b5892d22e9315d9c307f xendomains.initd"