aboutsummaryrefslogtreecommitdiffstats
path: root/testing/xpdf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/xpdf/APKBUILD')
-rw-r--r--testing/xpdf/APKBUILD62
1 files changed, 62 insertions, 0 deletions
diff --git a/testing/xpdf/APKBUILD b/testing/xpdf/APKBUILD
new file mode 100644
index 0000000000..196c9d9190
--- /dev/null
+++ b/testing/xpdf/APKBUILD
@@ -0,0 +1,62 @@
+# Contributor: Isaac Dunham <ibid.ag@gmail.com>
+# Maintainer: Isaac Dunham <ibid.ag@gmail.com>
+pkgname=xpdf
+pkgver="3.04"
+pkgrel=0
+pkgdesc="The classic X11 PDF viewer"
+url="http://foolabs.com/xpdf"
+arch="all"
+license="GPL2/GPL3"
+depends=""
+depends_dev=""
+makedepends="motif-dev freetype-dev libpng-dev"
+install=""
+subpackages="$pkgname-doc"
+source="ftp://ftp.foolabs.com/pub/xpdf/$pkgname-$pkgver.tar.gz
+xpdf-3.04-protection.patch"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ echo "$_builddir"
+ cd "$_builddir"
+ ./configure \
+ --with-x \
+ --with-freetype2-includes=/usr/include/freetype2 \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+ #delete pdf* utils that conflict with poppler-utils.
+ for i in pdftops pdftotxt pdfinfo pdfdetach; do
+ rm -f "$pkgdir"/usr/bin/$i
+ rm -f "$pkgdir"/usr/share/man/man1/$i.1
+ done
+}
+
+md5sums="3bc86c69c8ff444db52461270bef3f44 xpdf-3.04.tar.gz
+11bd32802d9e600ad028f5b84194178d xpdf-3.04-protection.patch"
+sha256sums="11390c74733abcb262aaca4db68710f13ffffd42bfe2a0861a5dfc912b2977e5 xpdf-3.04.tar.gz
+5a12a1781eb29f83b3f0e3c1484e6c99537f84e42aa3dda9bb9c4a5befd83217 xpdf-3.04-protection.patch"
+sha512sums="3fb3c380fdbd13d937449ae3f7d7a163815cc85296d30be7b9907687884385d6171bb48ee5d5c13368d6bba87740b678f491bdcf61b38d130809e9afa260f6cf xpdf-3.04.tar.gz
+4c6360731ad60ed45e0612b016116a9588f293267ee3e2c1f7cd2f046f045f165334c6e7fceb6b51b3181adb7a74087036a28fcec0e04b23e6374ffc421c1f54 xpdf-3.04-protection.patch"