aboutsummaryrefslogtreecommitdiffstats
path: root/testing/xulrunner/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/xulrunner/APKBUILD')
-rw-r--r--testing/xulrunner/APKBUILD110
1 files changed, 0 insertions, 110 deletions
diff --git a/testing/xulrunner/APKBUILD b/testing/xulrunner/APKBUILD
deleted file mode 100644
index 82bd902759..0000000000
--- a/testing/xulrunner/APKBUILD
+++ /dev/null
@@ -1,110 +0,0 @@
-# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: William Pitcock <nenolod@dereferenced.org>
-pkgname=xulrunner
-pkgver=9.0.1
-_ffoxver=9.0.1
-pkgrel=1
-pkgdesc="runtime environment for xul-based applications"
-url="http://developer.mozilla.org/en/XULRunner"
-arch="all"
-license="GPL LGPL MPL"
-depends=
-depends_dev="nspr-dev
- nss-dev
- gtk+-dev
- dbus-glib-dev
- alsa-lib-dev
- libvorbis-dev
- libogg-dev
- libtheora-dev
- wireless-tools-dev
- libnotify-dev
- libevent-dev
- libxt-dev
- jpeg-dev
- bzip2-dev
- hunspell-dev
- startup-notification-dev
- sqlite-dev
- libidl-dev
- mesa-dev"
-makedepends="$depends_dev
-
- autoconf2.13
-
- python
- zip
- yasm
-
- autoconf
- automake
- libtool"
-install=""
-subpackages="$pkgname-dev"
-# http://releases.mozilla.org/pub/mozilla.org/xulrunner/releases/${pkgver}/source/${pkgname}-${pkgver}.source.tar.bz2
-source="http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${_ffoxver}/source/firefox-${_ffoxver}.source.tar.bz2
-
- mozconfig
- 0002-Use-C99-math-isfinite.patch
- 0003-xulrunner-jemalloc-aslr.patch
- 0004-xulrunner-malloc_usable_size.patch
- ff9-aslr-fix.patch
- "
-
-_builddir="${srcdir}/mozilla-release"
-prepare() {
- local i
-
- cd "$_builddir"
-
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-
- cp "${srcdir}/mozconfig" .mozconfig
-}
-
-build() {
- cd "$_builddir"
-
- # mozilla's buildsystem is on drugs, so we just kill our CFLAGS and hope
- # for the best. --nenolod
- unset CFLAGS
- unset CXXFLAGS
-
- make -j1 -f client.mk build MOZ_MAKE_FLAGS="$MAKEFLAGS" || return 1
-}
-
-package() {
- cd "$_builddir"
- make -j1 DESTDIR="$pkgdir" -f client.mk install || return 1
-
- # make install does not install xpt.py but its needed by firefox
- mkdir -p "$pkgdir"/usr/lib/xulrunner-devel-$pkgver/sdk/bin
- cp xpcom/typelib/xpt/tools/xpt.py \
- "$pkgdir"/usr/lib/xulrunner-devel-$pkgver/sdk/bin/
-
- msg "Setting up compatibility symlinks..."
- ln -sf /usr/lib/xulrunner-${pkgver}/libxul.so "${pkgdir}"/usr/lib/libxul.so
- ln -sf /usr/lib/xulrunner-${pkgver}/libxpcom.so "${pkgdir}"/usr/lib/libxpcom.so
- ln -sf /usr/lib/xulrunner-${pkgver}/libmozalloc.so "${pkgdir}"/usr/lib/libmozalloc.so
-}
-
-dev() {
- replaces="xulrunner"
- depends="xulrunner"
-
- mkdir -p "${subpkgdir}"/usr/lib
- mv "${pkgdir}"/usr/lib/xulrunner-devel-${pkgver} "${subpkgdir}"/usr/lib
- mv "${pkgdir}"/usr/lib/pkgconfig "${subpkgdir}"/usr/lib
- mv "${pkgdir}"/usr/include "${subpkgdir}"/usr/include
-}
-
-md5sums="7cf2bd379792a9b232267c6a79680566 firefox-9.0.1.source.tar.bz2
-b0f7d491bc800b69ec718667a4b08acb mozconfig
-1867db217d10722675c88b655db8c2d7 0002-Use-C99-math-isfinite.patch
-7faa279d64c9ec2e7abc7c0497c7e07e 0003-xulrunner-jemalloc-aslr.patch
-7cf18be3ada3eed5856fbab24219126d 0004-xulrunner-malloc_usable_size.patch
-96b40acd003a0a586e408bf09ae5af1d ff9-aslr-fix.patch"