aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/libupnp/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/libupnp/APKBUILD b/testing/libupnp/APKBUILD
new file mode 100644
index 0000000000..4964dd5110
--- /dev/null
+++ b/testing/libupnp/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=libupnp
+pkgver=1.6.13
+pkgrel=0
+pkgdesc="Portable Open Source UPnP Development Kit"
+url="http://pupnp.sourceforge.net/"
+arch="all"
+license="BSD"
+depends=
+depends_dev=
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/sourceforge/pupnp/${pkgname}-${pkgver}.tar.bz2"
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/custom/${pkgname}/LICENSE
+}
+
+md5sums="71476b1781ad179bfc9bead640be5f54 libupnp-1.6.13.tar.bz2"