aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/nodejs-async/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/nodejs-async/APKBUILD b/testing/nodejs-async/APKBUILD
new file mode 100644
index 0000000000..39abf5b678
--- /dev/null
+++ b/testing/nodejs-async/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Eivind Uggedal <eivind@uggedal.com>
+pkgname=nodejs-async
+_pkgname=${pkgname#nodejs-}
+pkgver=0.9.0
+pkgrel=0
+pkgdesc="Higher-order functions and common patterns for asynchronous code"
+url="https://github.com/caolan/async"
+arch="noarch"
+license="MIT"
+depends="nodejs"
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="https://registry.npmjs.org/$_pkgname/-/$_pkgname-$pkgver.tgz"
+
+_builddir="$srcdir/package"
+_moduledir=usr/lib/node_modules/$_pkgname
+
+package() {
+ cd "$_builddir"
+
+ mkdir -p "$pkgdir"/$_moduledir
+ cp -pr package.json lib "$pkgdir"/$_moduledir
+}
+
+md5sums="25159ae88b0a2e14ca0860a71e6f61c9 async-0.9.0.tgz"
+sha256sums="fe953668526b50e8aced19d0c5ad5c224ea8c0ec3427a0f03f2aa0043f487575 async-0.9.0.tgz"
+sha512sums="5d0277322a660870080413057eeda36927ad9de3ab5db4b2caa794dcda1df3aee834ea52fa2f45126b393d68233314a00726d17f621554bb6bd587eb0cefa892 async-0.9.0.tgz"