aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/ipt-netflow-grsec/APKBUILD7
-rw-r--r--testing/ruby-nokogiri/APKBUILD2
-rw-r--r--testing/spl-grsec/APKBUILD2
-rw-r--r--testing/stfl/APKBUILD48
-rw-r--r--testing/stfl/libiconv.patch13
-rw-r--r--testing/stfl/libs.patch57
-rw-r--r--testing/stfl/ncurses.patch13
-rw-r--r--testing/virtualbox-additions-grsec/APKBUILD2
-rw-r--r--testing/wanpipe-grsec/APKBUILD2
-rw-r--r--testing/zfs-grsec/APKBUILD2
10 files changed, 138 insertions, 10 deletions
diff --git a/testing/ipt-netflow-grsec/APKBUILD b/testing/ipt-netflow-grsec/APKBUILD
index 6827ad8e26..a2a5393993 100644
--- a/testing/ipt-netflow-grsec/APKBUILD
+++ b/testing/ipt-netflow-grsec/APKBUILD
@@ -3,13 +3,13 @@
_flavor=grsec
_kpkg=linux-$_flavor
-_kver=3.8.6
+_kver=3.8.7
_kpkgrel=0
# when chaning _ver we *must* bump _mypkgrel
_ver=1.8.4
-_mypkgrel=1
+_mypkgrel=0
# verify the kernel version before entering chroot
if [ -f ../linux-${_flavor}/APKBUILD ]; then
@@ -53,9 +53,6 @@ build() {
--ipt-inc=/usr/include/libiptc \
|| return 1
make ipt_NETFLOW.ko
-
- # verify that it was built with constify:
- strings ipt_NETFLOW.ko | grep '^vermagic=.*CONSTIFY_PLUGIN' || return 1
}
package() {
diff --git a/testing/ruby-nokogiri/APKBUILD b/testing/ruby-nokogiri/APKBUILD
index 9a3f8f7df7..506dbb2a80 100644
--- a/testing/ruby-nokogiri/APKBUILD
+++ b/testing/ruby-nokogiri/APKBUILD
@@ -3,7 +3,7 @@
_gemname=nokogiri
pkgname=ruby-$_gemname
pkgver=1.5.6
-pkgrel=0
+pkgrel=1
pkgdesc="An HTML, XML, SAX, and Reader parser"
url="http://nokogiri.org/"
arch="all"
diff --git a/testing/spl-grsec/APKBUILD b/testing/spl-grsec/APKBUILD
index 198bfc77fc..9f8628f953 100644
--- a/testing/spl-grsec/APKBUILD
+++ b/testing/spl-grsec/APKBUILD
@@ -5,7 +5,7 @@ _realname=spl
_name=$_realname-$_flavor
_kpkg=linux-$_flavor
-_kver=3.8.6
+_kver=3.8.7
_kpkgrel=0
_realver=0.6.0-rc14
diff --git a/testing/stfl/APKBUILD b/testing/stfl/APKBUILD
new file mode 100644
index 0000000000..d10829ec35
--- /dev/null
+++ b/testing/stfl/APKBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=stfl
+pkgver=0.22
+pkgrel=0
+pkgdesc="The Structured Terminal Forms Language/Library"
+url="http://www.clifford.at/stfl/"
+arch="all"
+license="LGPLv3+"
+depends=""
+depends_dev=""
+makedepends="$depends_dev ncurses-dev libiconv-dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://www.clifford.at/stfl/stfl-$pkgver.tar.gz
+ ncurses.patch
+ libs.patch"
+
+_builddir="$srcdir"/stfl-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la "$pkgdir"/usr/lib/*.a
+}
+
+md5sums="df4998f69fed15fabd702a25777f74ab stfl-0.22.tar.gz
+43f04a9e6d1b544f6b60327b6d52b456 ncurses.patch
+c97e5120af576056f7bd55121b35dea8 libs.patch"
+sha256sums="2dddafd331e61ad04baf1251ccecb3a69feaf99880dd75155be8423c1cc55418 stfl-0.22.tar.gz
+20d9acdde7da2fc03fa00cafdf3c689dfbd0131c085e12e6fbdc498ec6d37010 ncurses.patch
+2cec3f9e649cdb096361acc8dc5cf77cb4007795c7450683a9f4cd22187d67f5 libs.patch"
+sha512sums="dab2335ef00b65d00abda2a51fb5c667b48864b02ee82abee049f15fd9e2f272f21ec80d4a6cdbb5fc5882239ba28964912e4c0b641b2e83a7ab3bd7f94415bb stfl-0.22.tar.gz
+2f31207d7fff88724a539ec7add1ad9f305e9adb36326acc6e42b6c27b0d93f74dc254b9f91c9b0ce0fb1d7d7c3d7d65defbc2086e9868108641df3a47e77166 ncurses.patch
+def75440a498d592aa5ee7e3b8302f863ec4f01e6a08264db221c390acc92d1d38eec9032ec9abd1af469ea5622ac1f8caf9c0aaba1a9e81434ddab4631ace4e libs.patch"
diff --git a/testing/stfl/libiconv.patch b/testing/stfl/libiconv.patch
new file mode 100644
index 0000000000..e96f8024de
--- /dev/null
+++ b/testing/stfl/libiconv.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index d481e68..55aa66e 100644
+--- a/Makefile
++++ b/Makefile
+@@ -22,7 +22,7 @@ include Makefile.cfg
+
+ export CC = gcc -pthread
+ export CFLAGS += -I. -Wall -Os -ggdb -D_GNU_SOURCE -fPIC
+-export LDLIBS += -lncursesw
++export LDLIBS += -lncursesw -liconv
+
+ SONAME := libstfl.so.0
+ VERSION := 0.22
diff --git a/testing/stfl/libs.patch b/testing/stfl/libs.patch
new file mode 100644
index 0000000000..ce093ceaed
--- /dev/null
+++ b/testing/stfl/libs.patch
@@ -0,0 +1,57 @@
+diff --git a/Makefile b/Makefile
+index d481e68..f7452b5 100644
+--- a/Makefile
++++ b/Makefile
+@@ -22,7 +22,7 @@ include Makefile.cfg
+
+ export CC = gcc -pthread
+ export CFLAGS += -I. -Wall -Os -ggdb -D_GNU_SOURCE -fPIC
+-export LDLIBS += -lncursesw
++export LDLIBS += -lncursesw -liconv
+
+ SONAME := libstfl.so.0
+ VERSION := 0.22
+@@ -39,7 +39,7 @@ libstfl.a: public.o base.o parser.o dump.o style.o binding.o iconv.o \
+
+ libstfl.so.$(VERSION): public.o base.o parser.o dump.o style.o binding.o iconv.o \
+ $(patsubst %.c,%.o,$(wildcard widgets/*.c))
+- $(CC) -shared -Wl,-soname,$(SONAME) -o $@ $(LDLIBS) $^
++ $(CC) -shared $(LDLIBS) -Wl,-soname,$(SONAME) -o $@ $(LDLIBS) $^
+
+ clean:
+ rm -f libstfl.a example core core.* *.o Makefile.deps
+@@ -65,6 +65,7 @@ install: all stfl.pc
+ install -m 644 stfl.pc $(DESTDIR)$(prefix)/$(libdir)/pkgconfig/
+ install -m 644 libstfl.so.$(VERSION) $(DESTDIR)$(prefix)/$(libdir)
+ ln -fs libstfl.so.$(VERSION) $(DESTDIR)$(prefix)/$(libdir)/libstfl.so
++ ln -fs libstfl.so.$(VERSION) $(DESTDIR)$(prefix)/$(libdir)/$(SONAME)
+
+ stfl.pc: stfl.pc.in
+ sed 's,@VERSION@,$(VERSION),g' < $< | sed 's,@PREFIX@,$(prefix),g' > $@
+diff --git a/Makefile.cfg b/Makefile.cfg
+index af3e102..346682e 100644
+--- a/Makefile.cfg
++++ b/Makefile.cfg
+@@ -19,7 +19,7 @@
+ #
+
+ export libdir ?= lib
+-export prefix ?= /usr/local
++export prefix ?= /usr
+ export DESTDIR ?= /
+
+ ifneq ($(shell spl-config --cflags 2>/dev/null),)
+diff --git a/python/Makefile.snippet b/python/Makefile.snippet
+index 8fd4052..af95b01 100644
+--- a/python/Makefile.snippet
++++ b/python/Makefile.snippet
+@@ -33,8 +33,7 @@ python/_stfl.so python/stfl.py python/stfl.pyc: libstfl.a stfl.h python/stfl.i s
+
+ install_python: python/_stfl.so python/stfl.py python/stfl.pyc
+ mkdir -p $(DESTDIR)$(PYTHON_SITEARCH)/
+- mkdir -p $(DESTDIR)$(PYTHON_SITEARCH)/lib-dynload/
+- cp python/_stfl.so $(DESTDIR)$(PYTHON_SITEARCH)/lib-dynload/
++ cp python/_stfl.so $(DESTDIR)$(PYTHON_SITEARCH)//
+ cp python/stfl.pyc $(DESTDIR)$(PYTHON_SITEARCH)/
+ cp python/stfl.py $(DESTDIR)$(PYTHON_SITEARCH)/
+
diff --git a/testing/stfl/ncurses.patch b/testing/stfl/ncurses.patch
new file mode 100644
index 0000000000..c74252a144
--- /dev/null
+++ b/testing/stfl/ncurses.patch
@@ -0,0 +1,13 @@
+diff --git a/stfl_internals.h b/stfl_internals.h
+index 3f9f45b..1559626 100644
+--- a/stfl_internals.h
++++ b/stfl_internals.h
+@@ -28,7 +28,7 @@ extern "C" {
+ #endif
+
+ #include "stfl.h"
+-#include <ncursesw/ncurses.h>
++#include <ncurses.h>
+ #include <pthread.h>
+
+ struct stfl_widget_type;
diff --git a/testing/virtualbox-additions-grsec/APKBUILD b/testing/virtualbox-additions-grsec/APKBUILD
index c11b865e1b..93b2834fd2 100644
--- a/testing/virtualbox-additions-grsec/APKBUILD
+++ b/testing/virtualbox-additions-grsec/APKBUILD
@@ -2,7 +2,7 @@
_flavor=grsec
_kpkg=linux-$_flavor
-_kver=3.8.6
+_kver=3.8.7
_kpkgrel=0
# when chaning _ver we *must* bump _mypkgrel
diff --git a/testing/wanpipe-grsec/APKBUILD b/testing/wanpipe-grsec/APKBUILD
index 93a2a200df..d5bab0cc1d 100644
--- a/testing/wanpipe-grsec/APKBUILD
+++ b/testing/wanpipe-grsec/APKBUILD
@@ -4,7 +4,7 @@ _realname=wanpipe
_name=$_realname-$_flavor
_kpkg=linux-$_flavor
-_kver=3.8.6
+_kver=3.8.7
_kpkgrel=0
# source the kernel version
diff --git a/testing/zfs-grsec/APKBUILD b/testing/zfs-grsec/APKBUILD
index 3596920c44..614cf2a9b8 100644
--- a/testing/zfs-grsec/APKBUILD
+++ b/testing/zfs-grsec/APKBUILD
@@ -6,7 +6,7 @@ _realname=zfs
_name=$_realname-$_flavor
_kpkg=linux-$_flavor
-_kver=3.8.6
+_kver=3.8.7
_kpkgrel=0
_realver=0.6.0-rc14