aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/milter-greylist/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/testing/milter-greylist/APKBUILD b/testing/milter-greylist/APKBUILD
index 75780798b6..d93daae7d7 100644
--- a/testing/milter-greylist/APKBUILD
+++ b/testing/milter-greylist/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=milter-greylist
pkgver=4.4.3
-pkgrel=2
+pkgrel=3
pkgdesc="Stand-alone milter written in C that implements the greylist filtering method"
url="http://hcpnet.free.fr/milter-greylist"
arch="all"
@@ -41,7 +41,11 @@ build() {
--localstatedir=/var/lib \
--with-libspf2 \
--with-user=smmsp \
+ --with-conffile=/etc/$pkgname/greylist.conf \
+ --with-dumpfile=/var/lib/$pkgname/greylist.db \
+ --with-libbind \
--enable-postfix \
+ --enable-spamassassin \
--disable-rpath
make -j1 || return 1
}
@@ -50,7 +54,7 @@ package() {
cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
install -m755 -D ../../$pkgname.initd "$pkgdir"/etc/init.d/$pkgname || return 1
- install -m644 greylist2.conf "$pkgdir"/etc/mail/greylist2.conf
+ install -m644 greylist2.conf "$pkgdir"/etc/$pkgname/greylist2.conf
chown -R smmsp:smmsp "$pkgdir"/var/lib/$pkgname
}