aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-specio/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/perl-specio/APKBUILD b/testing/perl-specio/APKBUILD
new file mode 100644
index 0000000000..2759159e59
--- /dev/null
+++ b/testing/perl-specio/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Breno Leitao <breno.leitao@gmail.com>
+# Maintainer: Breno Leitao <breno.leitao@gmail.com>
+pkgname=perl-specio
+_pkgname=Specio
+pkgver=0.36
+pkgrel=0
+pkgdesc="Type constraints and coercions for Perl"
+url="https://github.com/houseabsolute/Specio"
+arch="all"
+license="Artistic"
+depends=""
+makedepends=""
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/houseabsolute/$_pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="739007e046d7f2d6a40e561ea9aeffea298fd111b3aa66f1f964fd80843319e0cbd83f39f9457ce3e8d59973313a35ead8065a94588fed84d687cc8ea5634501 perl-specio-0.36.tar.gz"