aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/zathura/APKBUILD21
-rw-r--r--testing/zathura/without-synctex.patch53
2 files changed, 66 insertions, 8 deletions
diff --git a/testing/zathura/APKBUILD b/testing/zathura/APKBUILD
index 11a43ac247..33733e72d2 100644
--- a/testing/zathura/APKBUILD
+++ b/testing/zathura/APKBUILD
@@ -1,18 +1,20 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Contributor: Andrew Hills <ahills@ednos.net>
# Maintainer: Andrew Hills <ahills@ednos.net>
pkgname=zathura
-pkgver=0.3.3
+pkgver=0.3.4
pkgrel=0
pkgdesc="Document viewer with Vim-like controls"
-url="https://pwmt.org/projects/zathura"
+url="https://pwmt.org/projects/$pkgname"
arch="all"
license="zlib"
depends=""
depends_dev=""
-makedepends="$depends_dev girara-dev gtk+3.0-dev glib-dev file-dev ncurses"
+makedepends="girara-dev gtk+3.0-dev glib-dev file-dev"
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="https://pwmt.org/projects/zathura/download/zathura-$pkgver.tar.gz"
+source="https://pwmt.org/projects/$pkgname/download/$pkgname-$pkgver.tar.gz
+ without-synctex.patch"
_builddir="$srcdir"/zathura-$pkgver
prepare() {
@@ -20,7 +22,7 @@ prepare() {
cd "$_builddir"
for i in $source; do
case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ *.patch) msg $i; patch -p0 -i "$srcdir"/$i || return 1;;
esac
done
}
@@ -35,6 +37,9 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="d360252210ce51a29e8d341b1b72a7cc zathura-0.3.3.tar.gz"
-sha256sums="3347decfc8d4b918a6bca1d44657c3b97d4afcea3c8c1f162c57198b13e8dce7 zathura-0.3.3.tar.gz"
-sha512sums="0bfcb2c9ca6e7cf44db1c04fdcc5e1e2122b5bd060c10b711a331f885371a523881a46376c770b60cf199530fd9c7814248e8a6da556da8cd464a3a85dbad8e3 zathura-0.3.3.tar.gz"
+md5sums="64a19c0a78d06e3a8c2098911d59b072 zathura-0.3.4.tar.gz
+cf64a40358d705cee2d8174498d56e9f without-synctex.patch"
+sha256sums="52c4a3efc5843ce7c720ea7357667699363c809fd34ada4cb350d0e1031d0234 zathura-0.3.4.tar.gz
+e6cb2e825c584a82283a580fdd77428e91321f46d929eff42979e858eb9eac81 without-synctex.patch"
+sha512sums="663a24574838fe6531bf588ec97ed54f3bf3601c6ed11bbcd38347e8fa1876c4cfa964ab7bba70f8afd40dd9d984315b0966546394c0efac00c6fbd9967b77a2 zathura-0.3.4.tar.gz
+e750c8b2d7de3fdfe8275fe3c625bce6d3d9c12a956d0ea56a0af6848ecdd8cd903ba363fcff829024adc493b8c4f4b271f9f1d6dee52a3b14405df9b42b0ee0 without-synctex.patch"
diff --git a/testing/zathura/without-synctex.patch b/testing/zathura/without-synctex.patch
new file mode 100644
index 0000000000..b12ca3117e
--- /dev/null
+++ b/testing/zathura/without-synctex.patch
@@ -0,0 +1,53 @@
+From 5b3c183a9f8edf778f405f5da9b1ef8384775852 Mon Sep 17 00:00:00 2001
+From: Jan Palus <jan.palus@gmail.com>
+Date: Mon, 28 Dec 2015 22:19:07 +0100
+Subject: [PATCH] fix build without synctex
+
+---
+ zathura/main.c | 19 ++++++++++++-------
+ 1 file changed, 12 insertions(+), 7 deletions(-)
+
+diff --git a/zathura/main.c b/zathura/main.c
+index 060382a..3278dbe 100644
+--- zathura/main.c
++++ zathura/main.c
+@@ -84,12 +84,14 @@ run_synctex_forward(const char* synctex_fwd, const char* filename,
+
+ static zathura_t*
+ init_zathura(const char* config_dir, const char* data_dir,
+- const char* cache_dir, const char* plugin_path, char** argv,
++ const char* cache_dir, const char* plugin_path, char** argv
++#ifdef WITH_SYNCTEX
++ , char* synctex_editor
++#endif
+ #ifdef GDK_WINDOWING_X11
+- char* synctex_editor, Window embed)
+-#else
+- char* synctex_editor)
++ , Window embed
+ #endif
++ )
+ {
+ /* create zathura session */
+ zathura_t* zathura = zathura_create();
+@@ -250,11 +252,14 @@ main(int argc, char* argv[])
+
+ /* Create zathura session */
+ zathura_t* zathura = init_zathura(config_dir, data_dir, cache_dir,
++ plugin_path, argv
++#ifdef WITH_SYNCTEX
++ , synctex_editor
++#endif
+ #ifdef GDK_WINDOWING_X11
+- plugin_path, argv, synctex_editor, embed);
+-#else
+- plugin_path, argv, synctex_editor);
++ , embed
+ #endif
++ );
+ if (zathura == NULL) {
+ girara_error("Could not initialize zathura.");
+ return -1;
+--
+libgit2 0.23.3
+