aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/netatalk/APKBUILD69
-rw-r--r--testing/netatalk/netatalk.initd19
2 files changed, 0 insertions, 88 deletions
diff --git a/testing/netatalk/APKBUILD b/testing/netatalk/APKBUILD
deleted file mode 100644
index 86258bf48b..0000000000
--- a/testing/netatalk/APKBUILD
+++ /dev/null
@@ -1,69 +0,0 @@
-# Contributor: Alexander Rigbo <alex@dnb.nu>
-# Maintainer: Alexander Rigbo <alex@dnb.nu>
-pkgname=netatalk
-pkgver=3.1.11
-pkgrel=0
-pkgdesc="Netatalk is a freely-available Open Source AFP fileserver"
-url="http://netatalk.sourceforge.net/"
-arch="all"
-license="GPL2"
-makedepends="acl-dev attr-dev db-dev libevent-dev libgcrypt-dev tdb-dev file"
-subpackages="$pkgname-doc $pkgname-dev"
-source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
- netatalk.initd"
-builddir="$srcdir/$pkgname-$pkgver"
-options="suid" # needed for /usr/bin/afppasswd
-
-build() {
- cd "$builddir"
-
- # Notes:
- # --without-libevent - don't use *bundled* libevent
- # --without-tdb - don't use *bundled* tdb
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --disable-silent-rules \
- --disable-zeroconf \
- --disable-tcp-wrappers \
- --enable-overwrite \
- --without-libiconv \
- --without-pam \
- --with-shadow \
- --without-kerberos \
- --without-ldap \
- --with-acls \
- --without-libevent \
- --with-libevent-header=/usr/include \
- --with-libevent-lib=/usr/lib \
- --with-bdb=/usr \
- --without-tdb \
- --without-dtrace \
- --without-afpstats \
- --with-lockfile=/var/lock/netatalk
- make
-}
-
-check() {
- cd "$builddir"
- make check
-}
-
-package() {
- cd "$builddir"
-
- make DESTDIR="$pkgdir" install
-
- # We don't build with dbug support.
- rm "$pkgdir"/etc/dbus-session.conf
- rm "$pkgdir"/usr/bin/afpstats
-
- install -m 755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
-}
-
-sha512sums="24d475f6eb2977e83bcbfb05c7284987a5f4aac56925c7d654df1728115259131a3fb090d07f64951f31fb313b79d912ad50e948ad400435bf3c9ff6f5d8f677 netatalk-3.1.11.tar.gz
-c4dc6b1967f4b86ee2f1cfc480edab5467fb1f67fd0cbbed23c8454568d0aaceeedaa23db90f8ca5b47f24d346f72d5e12307557edfeeefcbee003f85c56cced netatalk.initd"
diff --git a/testing/netatalk/netatalk.initd b/testing/netatalk/netatalk.initd
deleted file mode 100644
index 3fdb482de4..0000000000
--- a/testing/netatalk/netatalk.initd
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/sbin/openrc-run
-
-extra_started_commands="reload"
-description_reload="Reload configuration file"
-
-command="/usr/sbin/netatalk"
-
-depend() {
- need net
- use logger dns
- after firewall
-}
-
-reload() {
- ebegin "Reloading $name"
-
- start-stop-daemon --signal SIGHUP --name $command
- eend $?
-}