aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/ospd-netstat/APKBUILD35
-rw-r--r--testing/yara/APKBUILD28
2 files changed, 9 insertions, 54 deletions
diff --git a/testing/ospd-netstat/APKBUILD b/testing/ospd-netstat/APKBUILD
deleted file mode 100644
index 4178d1fb1e..0000000000
--- a/testing/ospd-netstat/APKBUILD
+++ /dev/null
@@ -1,35 +0,0 @@
-# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=ospd-netstat
-pkgver=1.0b1
-pkgrel=5
-_pkgid=2219
-pkgdesc="OSP server implementation to allow OpenVAS to remotel control nmap port scanner"
-url="http://www.openvas.org/"
-arch="noarch"
-license="GPL"
-depends="python3 ospd"
-makedepends="cmake python3-dev py3-setuptools"
-source="http://wald.intevation.org/frs/download.php/$_pkgid/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$pkgname-$pkgver
-
-build() {
- cd "$builddir"
- python3 setup.py build
-}
-
-check() {
- cd "$builddir"
- python3 setup.py check
-}
-
-package() {
- cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-
-
-md5sums="2ca9530e30a49594883a70a97269a6de ospd-netstat-1.0b1.tar.gz"
-sha256sums="a6c5f86adfaa1ee1622581882c9b8773b6079c93285de51a7865c1a44444d54f ospd-netstat-1.0b1.tar.gz"
-sha512sums="f5a439cd0f60073d5d25c4a10743945b8ef7eb041e0364f0ba73d250d0988b90d75f3156464433a7baab116680e3f54be2bb556053b0020177edca008cda0e69 ospd-netstat-1.0b1.tar.gz"
diff --git a/testing/yara/APKBUILD b/testing/yara/APKBUILD
index 4c37b2df85..eef947d86e 100644
--- a/testing/yara/APKBUILD
+++ b/testing/yara/APKBUILD
@@ -1,30 +1,22 @@
# Maintainer: Daniel Isaksen <d@duniel.no>
pkgname=yara
-pkgver=3.7.0
-pkgrel=3
+pkgver=3.11.0
+pkgrel=0
pkgdesc="The pattern matching swiss knife for malware researchers"
url="https://virustotal.github.io/yara/"
arch="all !armhf !armv7" # armhf: tests fail
license="BSD-3-Clause"
makedepends="automake file-dev openssl-dev autoconf libtool flex"
-source="$pkgname-$pkgver.tar.gz::https://github.com/VirusTotal/$pkgname/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/VirusTotal/yara/archive/v$pkgver.tar.gz"
subpackages="$pkgname-doc"
-builddir="$srcdir/$pkgname-$pkgver"
-options="!check" # test-rules crashes on hardened kernel
prepare() {
default_prepare
- # Delete re_lexer.c to force it to be build with new version
- # of flex, othwewise tests fail in some arches because of a bug
- # in older version of flex.
- # See: https://github.com/VirusTotal/yara/issues/771
- rm "$srcdir"/yara-3.7.0/libyara/re_lexer.c
+ autoreconf -fiv
}
build() {
- cd "$builddir"
- autoreconf -fiv
./configure \
--prefix=/usr \
--with-crypto \
@@ -32,17 +24,15 @@ build() {
make
}
+check() {
+ make check
+}
+
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -Dm 644 COPYING "$pkgdir/usr/share/licenses/$pkgname"/COPYING
install -Dm 644 README.md "$pkgdir/usr/share/doc/$pkgname"/README.md
cp -r docs "$pkgdir/usr/share/doc/$pkgname"
}
-check() {
- cd "$builddir"
- make check
-}
-
-sha512sums="cd0214d39c6d1c5bc8410a1ec67e42ec8a672be382fb11e0a0f98cb03af1ef5db92e74216a9b98a6bdedf9721d4470639e340edbd39ca0184233652839742a33 yara-3.7.0.tar.gz"
+sha512sums="26d800284a2de07195e4a480eb7125b1f5ad0265b284bfbeee10dbab162ea0f419c9e2ea5c4ed5fa25a46a2c9e3c6b077dfe1cafece79251e20d5d70f91b80a8 yara-3.11.0.tar.gz"