aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-geoip2/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/py3-geoip2/APKBUILD b/testing/py3-geoip2/APKBUILD
new file mode 100644
index 0000000000..e7458e285b
--- /dev/null
+++ b/testing/py3-geoip2/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
+# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
+pkgname=py3-geoip2
+pkgver=2.9.0
+pkgrel=0
+pkgdesc="An API for the GeoIP2 web services and databases"
+url="https://www.maxmind.com/en/home"
+arch="noarch"
+license="Apache-2.0"
+depends="py3-requests py3-maxminddb"
+makedepends="python3 py3-setuptools"
+checkdepends="py3-nose py3-mock"
+_test_data_commit=f6ed981c23b0eb33d7c07568e2177236252afda6
+source="$pkgname-$pkgver.tar.gz::https://github.com/maxmind/GeoIP2-python/archive/v${pkgver}.tar.gz
+ MaxMind-DB-test-data-$_test_data_commit.tar.gz::https://github.com/maxmind/MaxMind-DB/archive/$_test_data_commit.tar.gz"
+builddir="$srcdir/GeoIP2-python-$pkgver"
+
+prepare() {
+ cd "$srcdir"
+
+ # Submodule required for tests
+ cp -r "MaxMind-DB-$_test_data_commit/"* "$builddir/tests/data"
+
+ default_prepare
+}
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+
+ python3 setup.py test
+}
+
+package() {
+ cd "$builddir"
+
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="8631a41d9644887d0149678e40a5f9d03bba660853c308c43bf358cd49b3f021566b9d6f65b670c0c1c78bcb4cb7cb007ad2db6f3c032749afa454fc9e06d74c py3-geoip2-2.9.0.tar.gz
+f7b9d370c330980d9419c7bea486b258aef3fa8ab49f83b860ef73036fc577c402e2f631090c5d1d23f2a8e34f927030a8fc6dc15edcd8002136673685aecb12 MaxMind-DB-test-data-f6ed981c23b0eb33d7c07568e2177236252afda6.tar.gz"