aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-type-tiny/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/perl-type-tiny/APKBUILD b/testing/perl-type-tiny/APKBUILD
new file mode 100644
index 0000000000..334ea34d31
--- /dev/null
+++ b/testing/perl-type-tiny/APKBUILD
@@ -0,0 +1,38 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-type-tiny
+_pkgreal=Type-Tiny
+pkgver=1.004004
+pkgrel=0
+pkgdesc="tiny, yet Moo(se)-compatible type constraint"
+url="https://metacpan.org/release/Type-Tiny/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-exporter-tiny"
+depends="$cpandepends"
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/T/TO/TOBYINK/Type-Tiny-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="a1e09c5a3369e0a9ea8e172d86e68e818a720c5c4d633103a442fe389f7a8a7b4a03b2487ffd09f184caf4eca94ef471cc9293b04557b8d4dd260649b4121673 Type-Tiny-1.004004.tar.gz"