aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/kemoticons/APKBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/testing/kemoticons/APKBUILD b/testing/kemoticons/APKBUILD
index abfa4d4b44..9550e502fe 100644
--- a/testing/kemoticons/APKBUILD
+++ b/testing/kemoticons/APKBUILD
@@ -6,12 +6,12 @@ pkgrel=0
pkgdesc="Support for emoticons and emoticons themes"
arch="all"
url="https://community.kde.org/Frameworks"
-license="LGPL-2.1+ AND (LGPL-2.1-only OR LGPL-3.0-only)"
+license="LGPL-2.1-or-later AND (LGPL-2.1-only OR LGPL-3.0-only)"
depends_dev="karchive-dev kconfig-dev kservice-dev kcoreaddons-dev"
makedepends="$depends_dev extra-cmake-modules doxygen qt5-qttools-dev"
+checkdepends="xvfb-run"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc"
-options="!check" # Fails due to requiring running X11
build() {
cmake \
@@ -23,10 +23,9 @@ build() {
}
check() {
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
}
-
package() {
DESTDIR="$pkgdir" make install
}