aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/nextcloud/APKBUILD5
-rw-r--r--testing/nextcloud/nextcloud-config.php4
2 files changed, 7 insertions, 2 deletions
diff --git a/testing/nextcloud/APKBUILD b/testing/nextcloud/APKBUILD
index 861000946e..386b520f2e 100644
--- a/testing/nextcloud/APKBUILD
+++ b/testing/nextcloud/APKBUILD
@@ -58,8 +58,9 @@ package() {
mv * "$pkgdir"${_ncwwwdir} || return 1
chmod +x "$pkgdir"${_ncwwwdir}/occ || return 1
ln -s $_ncconfdir "$pkgdir"${_ncwwwdir}/config || return 1
- install -m664 .htaccess "$pkgdir"${_ncwwwdir}/.htaccess
- mv "$pkgdir"$_ncwwwdir/apps "$pkgdir"$_ncbasedir || return
+ install -m664 .htaccess "$pkgdir"${_ncwwwdir}/.htaccess || return 1
+ install -m664 ../../${pkgname}-config.php "$pkgdir"/etc/$pkgname/config.php || return 1
+ mv "$pkgdir"$_ncwwwdir/apps "$pkgdir"$_ncbasedir || return 1
ln -s $_ncappsdir "$pkgdir"$_ncwwwdir/apps || return 1
for dir in ${_ncconfdir} ${_ncdatadir} ${_ncappsdir}; do
chown -R :www-data "$pkgdir"$dir || return 1
diff --git a/testing/nextcloud/nextcloud-config.php b/testing/nextcloud/nextcloud-config.php
new file mode 100644
index 0000000000..e99829a7cc
--- /dev/null
+++ b/testing/nextcloud/nextcloud-config.php
@@ -0,0 +1,4 @@
+<?php
+$CONFIG = array (
+ 'datadirectory' => '/var/lib/nextcloud/data',
+);