aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/idris/APKBUILD20
-rw-r--r--testing/idris/cabal.config182
2 files changed, 101 insertions, 101 deletions
diff --git a/testing/idris/APKBUILD b/testing/idris/APKBUILD
index 9863c29580..4e31e8dc02 100644
--- a/testing/idris/APKBUILD
+++ b/testing/idris/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Mitch Tishmack <mitch.tishmack@gmail.com>
pkgname=idris
-pkgver=1.0
-pkgrel=1
+pkgver=1.3.0
+pkgrel=0
pkgdesc="A Language with Dependent Types"
url="http://www.idris-lang.org"
# Note: same as ghc, if it gets ported elsewhere this should run too.
@@ -37,6 +37,9 @@ cabal_update() {
# Add version tag at the first line.
sed -i "1i--$pkgver" cabal.config
+ # Remove rts/ghc-boot-sh package if they somehow got inserted
+ sed -i -e "s/.*rts.*//g" -e "s/.*ghc-boot-th.*//g" cabal.config
+
mv cabal.config "$startdir"/
cd "$startdir"
@@ -95,12 +98,15 @@ prepare() {
# Create Cabal sandbox that will be used for all subsequent cabal
# invocations. This is something like Python virtual env.
- HOME="$_cabal_home" cabal sandbox init
+ cmd="cabal sandbox init"
+ msg "$cmd"
+ HOME="$_cabal_home" $cmd
# Fetch all dependencies.
# Note: cabal-doctest is a transitive dependency for libffi-0.1 not idris
- HOME="$_cabal_home" cabal fetch --no-dependencies $(_cabal_pkgs) \
- cabal-doctest-1.0.2 libffi-0.1
+ cmd="cabal fetch --no-dependencies $(_cabal_pkgs) cabal-doctest-1.0.2 libffi-0.1"
+ msg "$cmd"
+ HOME="$_cabal_home" $cmd
}
build() {
@@ -155,5 +161,5 @@ package() {
mv usr/share/doc/LICENSE usr/share/licenses/$pkgname/
}
-sha512sums="a350004a8510f01d1cc8f965a9a4e2dab219f003980b98354ebb5ae42f73b32c90c98dce193943e9709d994cb92ad35814a46b79412a1afc85d42e1018c6ba10 idris-1.0.tar.gz
-adce625aed6ab6f36adf6d91e5671c85c91a1009e17419a88071e3cd500962c1c545406b2eb431cd3efa45d3dacadac913a9a27a5956e8233bd13b4630ff2ab4 cabal.config"
+sha512sums="d015d643e0c121702c8e1a8a27db0a4f071fae35437bb4835314e70499b1eae123ab92d8272f0b91fae6d03b46cceee887e27935c950341c0905a4cdb43cbb84 idris-1.3.0.tar.gz
+713ae5a61d5fe297a4e4afba61d8b5d4422183780e696bd3f6059a0753a391b4cbb869e1baed24203ad2f626421e5be9cd05785cf286e003ac236f0ed024f606 cabal.config"
diff --git a/testing/idris/cabal.config b/testing/idris/cabal.config
index 227ceea1d4..f7723faf36 100644
--- a/testing/idris/cabal.config
+++ b/testing/idris/cabal.config
@@ -1,105 +1,99 @@
---1.0
-constraints: aeson ==1.1.2.0,
- attoparsec ==0.13.1.0,
- array ==0.5.1.1,
- integer-gmp ==1.0.0.1,
- bytestring ==0.10.8.1,
- deepseq ==1.4.2.0,
- containers ==0.5.7.1,
- scientific ==0.3.4.12,
- binary ==0.8.3.0,
- hashable ==1.2.6.0,
- text ==1.2.2.1,
- integer-logarithms ==1.0.1,
- vector ==0.12.0.1,
- primitive ==0.6.2.0,
- transformers ==0.5.2.0,
- base-compat ==0.9.3,
- unix ==2.7.2.1,
- time ==1.6.0.1,
- dlist ==0.8.0.2,
- tagged ==0.8.5,
- template-haskell ==2.11.1.0,
- pretty ==1.1.3.3,
- transformers-compat ==0.5.1.4,
- time-locale-compat ==0.1.1.3,
- unordered-containers ==0.2.8.0,
- uuid-types ==1.0.3,
- random ==1.1,
+--1.3.0
+constraints: Cabal ==2.2.0.1,
+ aeson ==1.2.4.0,
annotated-wl-pprint ==0.7.0,
- ansi-terminal ==0.6.2.3,
- ansi-wl-pprint ==0.6.7.3,
- async ==2.1.1.1,
- stm ==2.4.4.1,
+ ansi-terminal ==0.8.0.4,
+ ansi-wl-pprint ==0.6.8.2,
+ array ==0.5.2.0,
+ async ==2.2.1,
+ attoparsec ==0.13.2.2,
+ base ==4.11.1.0,
+ base-compat ==0.9.3,
+ base-orphans ==0.7,
base64-bytestring ==1.0.0.1,
- blaze-html ==0.9.0.1,
- blaze-builder ==0.4.0.2,
- blaze-markup ==0.8.0.0,
- cheapskate ==0.1.0.5,
+ binary ==0.8.5.1,
+ blaze-builder ==0.4.1.0,
+ blaze-html ==0.9.1.1,
+ blaze-markup ==0.8.2.1,
+ bytestring ==0.10.8.2,
+ case-insensitive ==1.2.0.11,
+ cheapskate ==0.1.1,
+ code-page ==0.1.3,
+ colour ==2.3.4,
+ constraints ==0.10,
+ containers ==0.5.11.0,
+ css-text ==0.1.3.0,
data-default ==0.7.1.1,
data-default-class ==0.1.2.0,
data-default-instances-containers ==0.0.1,
data-default-instances-dlist ==0.0.1,
data-default-instances-old-locale ==0.0.1,
+ deepseq ==1.4.3.0,
+ digest ==0.0.1.2,
+ directory ==1.3.1.5,
+ dlist ==0.8.0.4,
+ enclosed-exceptions ==1.0.2,
+ exceptions ==0.10.0,
+ filepath ==1.4.2,
+ fingertree ==0.1.4.1,
+ fsnotify ==0.3.0.1,
+
+ ghc-prim ==0.5.2.0,
+ hashable ==1.2.7.0,
+ haskeline ==0.7.4.2,
+ hinotify ==0.3.10,
+ hsc2hs ==0.68.3,
+ ieee754 ==0.8.0,
+ integer-gmp ==1.0.2.0,
+ integer-logarithms ==1.0.2.1,
+ lifted-async ==0.10.0.2,
+ lifted-base ==0.2.3.12,
+ megaparsec ==6.5.0,
+ monad-control ==1.0.2.3,
+ mtl ==2.2.2,
+ network ==2.6.3.5,
+ network-uri ==2.6.1.0,
old-locale ==1.0.0.7,
- mtl ==2.2.1,
+ old-time ==1.1.0.3,
+ optparse-applicative ==0.14.2.0,
+ parsec ==3.1.13.0,
+ parser-combinators ==1.0.0,
+ pretty ==1.1.3.6,
+ primitive ==0.6.4.0,
+ process ==1.6.3.0,
+ random ==1.1,
+ regex-base ==0.93.2,
+ regex-tdfa ==1.2.3,
+
+ safe ==0.3.17,
+ scientific ==0.3.6.2,
+ semigroups ==0.18.4,
+ shelly ==1.8.1,
+ split ==0.2.3.3,
+ stm ==2.4.5.0,
syb ==0.7,
+ system-fileio ==0.3.16.3,
+ system-filepath ==0.4.14,
+ tagged ==0.8.5,
+ tagsoup ==0.14.6,
+ template-haskell ==2.13.0.0,
+ terminal-size ==0.3.2.1,
+ terminfo ==0.4.1.1,
+ text ==1.2.3.0,
+ th-abstraction ==0.2.6.0,
+ time ==1.8.0.2,
+ time-locale-compat ==0.1.1.4,
+ transformers ==0.5.5.0,
+ transformers-base ==0.4.5.2,
+ transformers-compat ==0.6.2,
uniplate ==1.6.12,
- xss-sanitize ==0.3.5.7,
- css-text ==0.1.2.2,
- network-uri ==2.6.1.0,
- parsec ==3.1.11,
- tagsoup ==0.14.1,
+ unix ==2.7.2.2,
+ unix-compat ==0.5.0.1,
+ unordered-containers ==0.2.9.0,
utf8-string ==1.0.1.1,
- code-page ==0.1.3,
- directory ==1.3.0.0,
- filepath ==1.4.1.1,
- fingertree ==0.1.1.0,
- fsnotify ==0.2.1,
- hinotify ==0.3.9,
- unix-compat ==0.4.3.1,
- haskeline ==0.7.3.0,
- terminfo ==0.4.0.2,
- ieee754 ==0.8.0,
- network ==2.6.3.1,
- optparse-applicative ==0.13.2.0,
- process ==1.4.3.0,
- parsers ==0.12.4,
- base-orphans ==0.6,
- charset ==0.3.7.1,
- semigroups ==0.18.3,
- regex-tdfa ==1.2.2,
- regex-base ==0.93.2,
- safe ==0.3.14,
- split ==0.2.3.2,
- terminal-size ==0.3.2.1,
- trifecta ==1.6.2.1,
- comonad ==5.0.1,
- contravariant ==1.4,
- StateVar ==1.1.0.4,
- void ==0.7.2,
- distributive ==0.5.2,
- lens ==4.15.2,
- bifunctors ==5.4.2,
- exceptions ==0.8.3,
- free ==4.12.4,
- prelude-extras ==0.4.0.3,
- profunctors ==5.2,
- semigroupoids ==5.2,
- kan-extensions ==5.0.2,
- adjunctions ==4.3,
- fail ==4.9.0.0,
- parallel ==3.2.1.1,
- reflection ==2.1.2,
- reducers ==3.12.1,
- vector-binary-instances ==0.2.3.5,
- zip-archive ==0.3.0.6,
- digest ==0.0.1.2,
- old-time ==1.1.0.3,
- zlib ==0.6.1.2,
- tasty ==0.11.2.1,
- clock ==0.7.2,
- unbounded-delays ==0.1.1.0,
- tasty-golden ==2.3.1.1,
- temporary ==1.2.0.4,
- tasty-rerun ==1.1.6
+ uuid-types ==1.0.3,
+ vector ==0.12.0.1,
+ vector-binary-instances ==0.2.4,
+ xss-sanitize ==0.3.5.7,
+ zip-archive ==0.3.2.5,
+ zlib ==0.6.2