aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/cegui06/APKBUILD50
-rw-r--r--testing/cegui06/cegui-0.6.2-gcc46.patch11
2 files changed, 0 insertions, 61 deletions
diff --git a/testing/cegui06/APKBUILD b/testing/cegui06/APKBUILD
deleted file mode 100644
index a833342a9a..0000000000
--- a/testing/cegui06/APKBUILD
+++ /dev/null
@@ -1,50 +0,0 @@
-# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=cegui06
-pkgver=0.6.2b
-pkgrel=0
-pkgdesc="CEGUI library 0.6 for apps which need this specific version"
-url="http://www.cegui.org.uk"
-arch="all"
-license="MIT and LGPLv2+"
-depends=""
-makedepends="freetype-dev pcre-dev expat-dev libice-dev libsm-dev glew-dev
- mesa-dev lua-dev"
-install=""
-subpackages="$pkgname-dev"
-source="http://downloads.sourceforge.net/crayzedsgui/CEGUI-$pkgver.tar.gz
- cegui-0.6.2-gcc46.patch"
-
-_builddir="$srcdir"/CEGUI-0.6.2
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var \
- --disable-samples \
- --with-pic \
- --with-default-xml-parser=ExpatParser \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- rm -f "$pkgdir"/usr/lib/*.la
-}
-
-md5sums="4fbd95e5a2ac1c7acf2a8f5df3ac6b93 CEGUI-0.6.2b.tar.gz
-c313bbb6fea733ff904f7f3b48f6a3d0 cegui-0.6.2-gcc46.patch"
diff --git a/testing/cegui06/cegui-0.6.2-gcc46.patch b/testing/cegui06/cegui-0.6.2-gcc46.patch
deleted file mode 100644
index 27c817cff4..0000000000
--- a/testing/cegui06/cegui-0.6.2-gcc46.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -up CEGUI-0.6.2/include/CEGUIBase.h~ CEGUI-0.6.2/include/CEGUIBase.h
---- CEGUI-0.6.2/include/CEGUIBase.h~ 2008-02-11 15:38:27.000000000 +0100
-+++ CEGUI-0.6.2/include/CEGUIBase.h 2011-02-13 20:06:29.477851548 +0100
-@@ -33,6 +33,7 @@
- #ifndef _CEGUIBase_h_
- #define _CEGUIBase_h_
-
-+#include <cstddef>
- #include <cassert>
-
- // bring in configuration options