aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/ghc/APKBUILD56
1 files changed, 26 insertions, 30 deletions
diff --git a/testing/ghc/APKBUILD b/testing/ghc/APKBUILD
index 9fb9b14500..36f2676dc7 100644
--- a/testing/ghc/APKBUILD
+++ b/testing/ghc/APKBUILD
@@ -5,38 +5,25 @@ pkgver=8.0.2
pkgrel=4
pkgdesc="The Glasgow Haskell Compiler"
url="http://haskell.org"
-subpackages="$pkgname-doc $pkgname-dev"
arch="x86_64 armhf"
-builddir="$srcdir/$pkgname-$pkgver"
-source="http://downloads.haskell.org/~ghc/${pkgver}/ghc-${pkgver}-src.tar.xz
- http://downloads.haskell.org/~ghc/${pkgver}/ghc-${pkgver}-testsuite.tar.xz
- 0000-alpine.patch
- 0000-bootstrap.patch
- 0001-rm-ghc-pwd.patch
- 0002-Correct-issue-with-libffi-and-glibc.patch
- 0003-do-not-use-SHELL.patch
- 0004-reproducible-tmp-names.patch
- 0005-buildpath-abi-stability.patch
- 0006-fix-madvise.patch
- 0007-build-hp2ps-twice.patch
- 0008-build-unlit-twice.patch
- "
-
-# Note ghc's license is basically bsd3. If you'd like to know more visit:
-# https://www.haskell.org/ghc/license
-# https://ghc.haskell.org/trac/ghc/wiki/Licensing
+# Note ghc's license is basically BSD-3. If you'd like to know more visit:
+# * https://www.haskell.org/ghc/license
+# * https://ghc.haskell.org/trac/ghc/wiki/Licensing
+license="custom:bsd3"
+# Note, gcc supports --no-pie on alpine linux 3.5+ only. We test for
+# that version as it greatly simplifies the apkbuild process. The
+# apks built on 3.5 will not work on any prior version of Alpine Linux.
#
# Note also that ghc is sensitive to the version of llvm used, hence the
# llvm3.7 package.
#
# Ref: https://ghc.haskell.org/trac/ghc/wiki/Status/GHC-8.0.1
# https://ghc.haskell.org/trac/ghc/wiki/ImprovedLLVMBackend
-license="custom:bsd3"
-
-# Note, gcc supports --no-pie on alpine linux 3.5+ only. We test for
-# that version as it greatly simplifies the apkbuild process. The
-# apks built on 3.5 will not work on any prior version of alpine linux.
depends="gmp-dev perl gcc>=6.2.1 llvm3.7 libffi-dev"
+makedepends_build="autoconf cpio binutils-gold paxmark ghc-bootstrap libffi-dev ncurses-dev"
+makedepends_host="linux-headers musl-dev zlib-dev gmp-dev binutils-dev libffi-dev ncurses-dev"
+makedepends="$makedepends_build $makedepends_host"
+checkdepends="python2"
provides="ghc-bootstrap=$pkgver-r$pkgrel
haskell-cabal=1.24.2.0
haskell-bytestring=0.10.8.1
@@ -63,13 +50,22 @@ provides="ghc-bootstrap=$pkgver-r$pkgrel
haskell-unix=2.7.2.1
haskell-xhtml=3000.2.1
"
+subpackages="$pkgname-doc $pkgname-dev"
install="$pkgname.post-install"
-
-# ghc build dependencies
-makedepends_build="autoconf cpio binutils-gold paxmark ghc-bootstrap libffi-dev ncurses-dev"
-makedepends_host="linux-headers musl-dev zlib-dev gmp-dev binutils-dev libffi-dev ncurses-dev"
-makedepends="$makedepends_build $makedepends_host"
-checkdepends="python2"
+source="http://downloads.haskell.org/~ghc/${pkgver}/ghc-${pkgver}-src.tar.xz
+ http://downloads.haskell.org/~ghc/${pkgver}/ghc-${pkgver}-testsuite.tar.xz
+ 0000-alpine.patch
+ 0000-bootstrap.patch
+ 0001-rm-ghc-pwd.patch
+ 0002-Correct-issue-with-libffi-and-glibc.patch
+ 0003-do-not-use-SHELL.patch
+ 0004-reproducible-tmp-names.patch
+ 0005-buildpath-abi-stability.patch
+ 0006-fix-madvise.patch
+ 0007-build-hp2ps-twice.patch
+ 0008-build-unlit-twice.patch
+ "
+builddir="$srcdir/$pkgname-$pkgver"
prepare() {
default_prepare || return 1