aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-nikola/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/testing/py3-nikola/APKBUILD b/testing/py3-nikola/APKBUILD
index a6f9b8cd9b..51d049dd39 100644
--- a/testing/py3-nikola/APKBUILD
+++ b/testing/py3-nikola/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-nikola
_pkgname=Nikola
pkgver=8.0.2
-pkgrel=0
+pkgrel=1
pkgdesc="A modular, fast, simple, static python website generator"
url="https://getnikola.com"
arch="noarch !s390x" # limited by py3-piexif
@@ -17,6 +17,9 @@ source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname
fix-requirements.patch"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-nikola" # Backwards compatibility
+provides="py-nikola=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
python3 setup.py build
}