aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/openimageio/APKBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/testing/openimageio/APKBUILD b/testing/openimageio/APKBUILD
index 713b937309..bec3fd6286 100644
--- a/testing/openimageio/APKBUILD
+++ b/testing/openimageio/APKBUILD
@@ -2,36 +2,33 @@
# Maintainer: Mark Riedesel <mark@klowner.com>
pkgname=openimageio
pkgver=1.8.15
-pkgrel=2
+pkgrel=3
pkgdesc="Image I/O library supporting a multitude of image formats"
+options="!check" # 100 out of 120 tests fail
url="https://sites.google.com/site/openimageio/"
-arch="all"
-license="BSD"
-depends=""
+arch="all !armv7"
+license="BSD-3-Clause"
# NOTE: OpenColorIO and OpenImageIO are cross dependent. If an ABI incompatible
# update is done in one, the other also needs to be rebuilt.
makedepends="cmake giflib-dev zlib-dev boost-dev libjpeg-turbo-dev libpng-dev tiff-dev
- glew-dev python2-dev>=2.6 openexr-dev ffmpeg-dev
+ glew-dev python3-dev openexr-dev ffmpeg-dev
libraw-dev libwebp-dev freetype-dev qt5-qtbase-dev mesa-dev openssl-dev
jasper-dev opencolorio-dev"
-subpackages="py2-$pkgname:_python $pkgname-dev $pkgname-doc $pkgname-tools"
+subpackages="py3-$pkgname:_python $pkgname-dev $pkgname-doc $pkgname-tools"
source="$pkgname-$pkgver.tar.gz::https://github.com/OpenImageIO/oiio/archive/Release-${pkgver}.tar.gz
boost-python.patch
"
-options="!check"
builddir="$srcdir/oiio-Release-$pkgver"
build() {
- cd "$builddir"
-
mkdir build && cd build
cmake .. \
-DUSE_OPENSSL=ON \
-DUSE_PYTHON=ON \
+ -DPYTHON_VERSION=3.7 \
-DUSE_NUKE=OFF \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DPYLIB_INSTALL_DIR=lib/python2.7/site-packages \
-DCMAKE_SKIP_RPATH=ON \
-DSTOP_ON_WARNING=OFF \
-DOIIO_BUILD_TESTS=OFF \
@@ -41,7 +38,7 @@ build() {
}
package() {
- cd "$builddir"/build
+ cd build
make DESTDIR="$pkgdir" install
}