aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/haproxy/APKBUILD40
-rw-r--r--testing/haproxy/haproxy.cfg86
-rw-r--r--testing/haproxy/haproxy.initd54
-rw-r--r--testing/haproxy/haproxy.pre-install12
-rw-r--r--testing/haproxy/haproxy.pre-upgrade12
5 files changed, 0 insertions, 204 deletions
diff --git a/testing/haproxy/APKBUILD b/testing/haproxy/APKBUILD
deleted file mode 100644
index 86be5e9f40..0000000000
--- a/testing/haproxy/APKBUILD
+++ /dev/null
@@ -1,40 +0,0 @@
-# Contributor: Jeff Bilyk <jbilyk@gmail.com>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=haproxy
-pkgver=1.5.10
-pkgrel=0
-pkgdesc="A TCP/HTTP reverse proxy for high availability environments"
-url="http://haproxy.1wt.eu"
-arch="all"
-license="GPL"
-depends=""
-makedepends="pcre-dev openssl-dev linux-headers"
-install="haproxy.pre-install haproxy.pre-upgrade"
-subpackages="$pkgname-doc"
-source="http://haproxy.1wt.eu/download/1.5/src/$pkgname-$pkgver.tar.gz
- haproxy.initd
- haproxy.cfg"
-
-build() {
- cd "$srcdir/$pkgname-$pkgver"
- make TARGET=linux2628 USE_PCRE=1 USE_OPENSSL=1 CFLAGS="$CFLAGS" || return 1
-}
-
-package() {
- cd "$srcdir/$pkgname-$pkgver"
- make DESTDIR="$pkgdir" PREFIX=/usr DOCDIR=/usr/share/doc/haproxy \
- install
- install -d "$pkgdir"/var/lib/haproxy
- install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
- install -m644 -D "$srcdir"/haproxy.cfg "$pkgdir"/etc/haproxy/haproxy.cfg
-}
-
-md5sums="5631457ea1f84b3c0d8e5bc8015ed329 haproxy-1.5.10.tar.gz
-81319456a35408bf47443e9c314d2e94 haproxy.initd
-463f00b30bfb002750d5c5549382365f haproxy.cfg"
-sha256sums="090264c834477c290f6ad6da558731d50aede0800996742d15e870b9947fe517 haproxy-1.5.10.tar.gz
-d0b91b3566768c40cfeb3b304d66728111d9b97d5c149d88589371c1bc4c6ba0 haproxy.initd
-7e3c03acb9a41e21e21059da609e694e6dd952d9a37297bd39cad37680af213f haproxy.cfg"
-sha512sums="d15aaca4be6d8b41a691509042728d6aaa177075f2c3ff783d91cc02150a0d7985863c2f0c19c5df20461fdf2c95eaca67031ed37992e75ac02fb887445308de haproxy-1.5.10.tar.gz
-cb13279374006b1a6302f865f82defbaa6256aed424fb12da53a9459a1a96c6f9470b8156985a177a13bda4a74e7b0cd448666564f6a59cdeb589537580f4b64 haproxy.initd
-89d1366352af9cc7cb338779341d460606e2e3cfe9e4f7d5169af46680accb07035fab9a4bbb87dfbe383bb146e8e4d1e95a29e3d36ff64e97603a317a0b1b78 haproxy.cfg"
diff --git a/testing/haproxy/haproxy.cfg b/testing/haproxy/haproxy.cfg
deleted file mode 100644
index 6f635e821d..0000000000
--- a/testing/haproxy/haproxy.cfg
+++ /dev/null
@@ -1,86 +0,0 @@
-#---------------------------------------------------------------------
-# Example configuration for a possible web application. See the
-# full configuration options online.
-#
-# http://haproxy.1wt.eu/download/1.5/doc/configuration.txt
-#
-#---------------------------------------------------------------------
-
-#---------------------------------------------------------------------
-# Global settings
-#---------------------------------------------------------------------
-global
- # to have these messages end up in /var/log/haproxy.log you will
- # need to:
- #
- # 1) configure syslog to accept network log events. This is done
- # by adding the '-r' option to the SYSLOGD_OPTIONS in
- # /etc/sysconfig/syslog
- #
- # 2) configure local2 events to go to the /var/log/haproxy.log
- # file. A line like the following can be added to
- # /etc/sysconfig/syslog
- #
- # local2.* /var/log/haproxy.log
- #
- log 127.0.0.1 local2
-
- chroot /var/lib/haproxy
- pidfile /var/run/haproxy.pid
- maxconn 4000
- user haproxy
- group haproxy
- daemon
-
- # turn on stats unix socket
- stats socket /var/lib/haproxy/stats
-
-#---------------------------------------------------------------------
-# common defaults that all the 'listen' and 'backend' sections will
-# use if not designated in their block
-#---------------------------------------------------------------------
-defaults
- mode http
- log global
- option httplog
- option dontlognull
- option http-server-close
- option forwardfor except 127.0.0.0/8
- option redispatch
- retries 3
- timeout http-request 10s
- timeout queue 1m
- timeout connect 10s
- timeout client 1m
- timeout server 1m
- timeout http-keep-alive 10s
- timeout check 10s
- maxconn 3000
-
-#---------------------------------------------------------------------
-# main frontend which proxys to the backends
-#---------------------------------------------------------------------
-frontend main *:5000
- acl url_static path_beg -i /static /images /javascript /stylesheets
- acl url_static path_end -i .jpg .gif .png .css .js
-
- use_backend static if url_static
- default_backend app
-
-#---------------------------------------------------------------------
-# static backend for serving up images, stylesheets and such
-#---------------------------------------------------------------------
-backend static
- balance roundrobin
- server static 127.0.0.1:4331 check
-
-#---------------------------------------------------------------------
-# round robin balancing between the various backends
-#---------------------------------------------------------------------
-backend app
- balance roundrobin
- server app1 127.0.0.1:5001 check
- server app2 127.0.0.1:5002 check
- server app3 127.0.0.1:5003 check
- server app4 127.0.0.1:5004 check
-
diff --git a/testing/haproxy/haproxy.initd b/testing/haproxy/haproxy.initd
deleted file mode 100644
index fb1d70ed81..0000000000
--- a/testing/haproxy/haproxy.initd
+++ /dev/null
@@ -1,54 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/files/haproxy.initd-r1,v 1.2 2011/12/04 10:32:32 swegener Exp $
-
-extra_commands="checkconfig"
-extra_started_commands="reload"
-command=/usr/sbin/haproxy
-
-CONFFILE=${HAPROXY_CONF:-/etc/haproxy/${SVCNAME}.cfg}
-PIDFILE=/var/run/${SVCNAME}.pid
-
-depend() {
- need net
- after firewall
- use dns logger
-}
-
-checkconfig() {
- if [ ! -f "${CONFFILE}" ]; then
- eerror "${CONFFILE} does not exist!"
- return 1
- fi
-
- ebegin "Checking ${CONFFILE}"
- $command -q -c -f "${CONFFILE}"
- eend $?
-}
-
-start() {
- ebegin "Starting ${SVCNAME}"
- start-stop-daemon --pidfile "${PIDFILE}" --exec $command \
- --start -- -D -p "${PIDFILE}" -f "${CONFFILE}"
- eend $?
-}
-
-stop() {
- ebegin "Stopping ${SVCNAME}"
-
- if [ "${RC_CMD}" = "restart" ]; then
- checkconfig || return 1
- fi
-
- start-stop-daemon --stop --pidfile "${PIDFILE}"
- eend $?
-}
-
-reload() {
- ebegin "Reloading ${SVCNAME}"
- checkconfig || { eerror "Reloading failed, please fix your ${CONFFILE} first"; return 1; }
- $command -D -p "${PIDFILE}" -f "${CONFFILE}" -sf $(cat "${PIDFILE}")
- eend $?
-}
-
diff --git a/testing/haproxy/haproxy.pre-install b/testing/haproxy/haproxy.pre-install
deleted file mode 100644
index 33e0164aff..0000000000
--- a/testing/haproxy/haproxy.pre-install
+++ /dev/null
@@ -1,12 +0,0 @@
-#!/bin/sh
-
-addgroup haproxy 2>/dev/null
-adduser -S -H -h /var/lib/haproxy -s /bin/false -D \
- -G haproxy haproxy 2>/dev/null
-
-# move config to new location
-if [ -e /etc/haproxy.cfg ] && ! [ -e /etc/haproxy/haproxy.cfg ]; then
- mkdir -p /etc/haproxy
- mv /etc/haproxy.cfg /etc/haproxy/haproxy.cfg
-fi
-
diff --git a/testing/haproxy/haproxy.pre-upgrade b/testing/haproxy/haproxy.pre-upgrade
deleted file mode 100644
index 33e0164aff..0000000000
--- a/testing/haproxy/haproxy.pre-upgrade
+++ /dev/null
@@ -1,12 +0,0 @@
-#!/bin/sh
-
-addgroup haproxy 2>/dev/null
-adduser -S -H -h /var/lib/haproxy -s /bin/false -D \
- -G haproxy haproxy 2>/dev/null
-
-# move config to new location
-if [ -e /etc/haproxy.cfg ] && ! [ -e /etc/haproxy/haproxy.cfg ]; then
- mkdir -p /etc/haproxy
- mv /etc/haproxy.cfg /etc/haproxy/haproxy.cfg
-fi
-