aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/apache-mod-auth-ntlm-winbind/APKBUILD34
-rw-r--r--testing/apache-mod-auth-ntlm-winbind/mod-auth-ntlm-winbind.conf1
-rw-r--r--testing/cacti/APKBUILD45
-rw-r--r--testing/lua-imlib2/APKBUILD33
-rw-r--r--testing/lua-rex/APKBUILD (renamed from testing/lua-rexlib/APKBUILD)0
-rw-r--r--testing/multipath-tools/APKBUILD4
-rw-r--r--testing/nagiosql/APKBUILD32
-rw-r--r--testing/nload/APKBUILD31
-rw-r--r--testing/open-vm-tools/APKBUILD2
-rw-r--r--testing/sircbot/APKBUILD21
-rw-r--r--testing/tinc/APKBUILD50
-rw-r--r--testing/tinc/tinc.networks13
-rw-r--r--testing/tinc/tincd.initd64
-rw-r--r--testing/tinc/tincd.lo.initd46
14 files changed, 365 insertions, 11 deletions
diff --git a/testing/apache-mod-auth-ntlm-winbind/APKBUILD b/testing/apache-mod-auth-ntlm-winbind/APKBUILD
new file mode 100644
index 0000000000..2a9bba0d9c
--- /dev/null
+++ b/testing/apache-mod-auth-ntlm-winbind/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Jeff Bilyk <jbilyk@gmail.com>
+# Maintainer: Natanael Copa <natanael.copa@gmail.com>
+pkgname=apache-mod-auth-ntlm-winbind
+pkgver=0.1
+pkgrel=0
+pkgdesc="Authentication module for Apache using NTLM protocol with winbind helper"
+url="http://samba.org/ftp/unpacked/lorikeet/mod_auth_ntlm_winbind/"
+license="Apache2"
+depends="apache2"
+makedepends="autoconf apache2-dev apr-util-dev apr-dev"
+source="http://samba.org/ftp/unpacked/lorikeet/mod_auth_ntlm_winbind/mod_auth_ntlm_winbind.c
+http://samba.org/ftp/unpacked/lorikeet/mod_auth_ntlm_winbind/configure.in
+http://samba.org/ftp/unpacked/lorikeet/mod_auth_ntlm_winbind/Makefile.in
+mod-auth-ntlm-winbind.conf"
+
+build() {
+ cd "$srcdir"
+ autoconf
+ ./configure
+ make DESTDIR="$pkgdir" || return 1
+}
+
+package() {
+ cd "$srcdir"
+ mkdir -p "$pkgdir"/etc/apache2/conf.d
+ mkdir -p "$pkgdir"/usr/lib/apache2
+ install mod-auth-ntlm-winbind.conf "$pkgdir"/etc/apache2/conf.d/mod-auth-ntlm-winbind.conf
+ install "$srcdir"/.libs/mod_auth_ntlm_winbind.so "$pkgdir"/usr/lib/apache2/mod_auth_ntlm_winbind.so
+}
+
+md5sums="01d32e311e6a404bcf4179c863081818 mod_auth_ntlm_winbind.c
+e1490dae6e468d4bc56154b16e5d8c24 configure.in
+410de8b0ac7ffe5c44a71d094190187d Makefile.in
+331b392c7aaa13b3a9ea8780ce2db3d4 mod-auth-ntlm-winbind.conf"
diff --git a/testing/apache-mod-auth-ntlm-winbind/mod-auth-ntlm-winbind.conf b/testing/apache-mod-auth-ntlm-winbind/mod-auth-ntlm-winbind.conf
new file mode 100644
index 0000000000..da7d99133a
--- /dev/null
+++ b/testing/apache-mod-auth-ntlm-winbind/mod-auth-ntlm-winbind.conf
@@ -0,0 +1 @@
+LoadModule auth_ntlm_winbind_module lib/apache2/mod_auth_ntlm_winbind.so
diff --git a/testing/cacti/APKBUILD b/testing/cacti/APKBUILD
new file mode 100644
index 0000000000..e7452bf63e
--- /dev/null
+++ b/testing/cacti/APKBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Jeff Bilyk <jbilyk@gmail.com>
+pkgname=cacti
+pkgver=0.8.7g
+pkgrel=0
+pkgdesc="Network monitoring tool based on RRDtool"
+url="http://www.cacti.net"
+license="GPL"
+depends="mysql php php-mysql php-snmp rrdtool net-snmp php-sockets php-xml php-gd"
+makedepends=
+source="http://www.cacti.net/downloads/$pkgname-$pkgver.tar.gz
+http://www.cacti.net/downloads/patches/$pkgver/data_source_deactivate.patch
+http://www.cacti.net/downloads/patches/$pkgver/graph_list_view.patch
+http://www.cacti.net/downloads/patches/$pkgver/html_output.patch
+http://www.cacti.net/downloads/patches/$pkgver/ldap_group_authenication.patch
+http://www.cacti.net/downloads/patches/$pkgver/script_server_command_line_parse.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ for i in ../*.patch; do
+ msg "Applying $i"
+ if ! patch -p1 -i $i; then
+ error "$i failed"
+ return 1
+ fi
+ done
+}
+
+build() {
+ cd "$_builddir"
+ return 0
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/share/webapps/cacti
+ mv "$srcdir"/$pkgname-$pkgver/* "$pkgdir"/usr/share/webapps/cacti/ || return 1
+
+}
+md5sums="268421cb1a58d3444f7ecbddb4c4b016 cacti-0.8.7g.tar.gz
+d39570fd2e2b5c7f9aa47000b8a28c42 data_source_deactivate.patch
+6c2f7db4af48e59323c5e8b25a34866b graph_list_view.patch
+134d120930e4f2211f017f5b71d9280a html_output.patch
+5bb62cc6fde7c99f0c29cab869412f73 ldap_group_authenication.patch
+e14edee082d1250e3946c3caa58a40b4 script_server_command_line_parse.patch"
diff --git a/testing/lua-imlib2/APKBUILD b/testing/lua-imlib2/APKBUILD
new file mode 100644
index 0000000000..4b8cea2f4e
--- /dev/null
+++ b/testing/lua-imlib2/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor:
+# Maintainer:
+pkgname=lua-imlib2
+pkgver=0.1
+pkgrel=0
+pkgdesc="A LUA binding to the Imlib2 image manipulation library"
+url="http://asbradbury.org/projects/lua-imlib2/"
+license="MIT"
+depends=
+makedepends="lua-dev imlib2-dev"
+install=
+source="http://luaforge.net/frs/download.php/3042/lua-imlib2-$pkgver.tar.gz"
+
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -D limlib2.so "$pkgdir"/usr/lib/lua/5.1/limlib2.so
+ install -D imlib2.lua "$pkgdir"/usr/share/lua/5.1/imlib2.lua
+}
+
+md5sums="f90d5d70ea8af6b66ee2e3071a08ec00 lua-imlib2-0.1.tar.gz"
diff --git a/testing/lua-rexlib/APKBUILD b/testing/lua-rex/APKBUILD
index 4f7bce0891..4f7bce0891 100644
--- a/testing/lua-rexlib/APKBUILD
+++ b/testing/lua-rex/APKBUILD
diff --git a/testing/multipath-tools/APKBUILD b/testing/multipath-tools/APKBUILD
index 471d9de2c5..bb6227f937 100644
--- a/testing/multipath-tools/APKBUILD
+++ b/testing/multipath-tools/APKBUILD
@@ -2,12 +2,12 @@
# Maintainer: Leonardo Arena <rnalrd@gmail.com>
pkgname="multipath-tools"
pkgver=0.4.8
-pkgrel=2
+pkgrel=3
pkgdesc="Device Mapper Multipathing Driver"
url="http://christophe.varoqui.free.fr/"
license="GPL"
depends=
-makedepends="lvm2-dev libaio-dev readline-dev"
+makedepends="lvm2-dev libaio-dev readline-dev ncurses-dev"
install=
subpackages="$pkgname-doc"
source="http://christophe.varoqui.free.fr/$pkgname/$pkgname-$pkgver.tar.bz2
diff --git a/testing/nagiosql/APKBUILD b/testing/nagiosql/APKBUILD
new file mode 100644
index 0000000000..65a9295dfa
--- /dev/null
+++ b/testing/nagiosql/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jeff Bilyk <jbilyk@gmail.com>
+pkgname=nagiosql
+pkgver=3.0.3
+_pkgverdown=303
+_pkgvermaj=3
+pkgrel=0
+pkgdesc="Web frontend to configure Nagios"
+url="http://www.nagiosql.org"
+license="GPL"
+depends="lighttpd mysql php php-gettext php-ftp php-pear"
+makedepends=
+source="http://downloads.sourceforge.net/$pkgname/${pkgname}${_pkgverdown}.tar.gz
+http://download.pear.php.net/package/HTML_Template_IT-1.3.0.tgz"
+
+_builddir="$srcdir"/${pkgname}${_pkgvermaj}
+
+build() {
+ cd "$_builddir"
+ return 0
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/share/webapps/nagiosql
+ mkdir -p "$pkgdir"/usr/share/pear
+ cp -r "$srcdir"/HTML_Template_IT-1.3.0/* "$pkgdir"/usr/share/pear/
+ cp -r "$_builddir"/* "$pkgdir"/usr/share/webapps/nagiosql/
+ touch "$pkgdir"/usr/share/webapps/nagiosql/install/ENABLE_INSTALLER
+}
+
+md5sums="3b15650942cf0fea3b6bbec1700ace38 nagiosql303.tar.gz
+cbd2fcffd32a39da7b260397156bddbb HTML_Template_IT-1.3.0.tgz"
diff --git a/testing/nload/APKBUILD b/testing/nload/APKBUILD
new file mode 100644
index 0000000000..90517ad3bf
--- /dev/null
+++ b/testing/nload/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Jeff Bilyk <jbilyk at gmail.com>
+# Maintainer:
+pkgname=nload
+pkgver=0.7.2
+pkgrel=1
+pkgdesc="Console network traffic and bandwidth monitor"
+url="http://www.roland-riegel.de/nload"
+license="GPL"
+depends=
+makedepends="ncurses-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="5b851ecf898edcd1f465946745e95eb6 nload-0.7.2.tar.gz"
diff --git a/testing/open-vm-tools/APKBUILD b/testing/open-vm-tools/APKBUILD
index 97a3a7753a..c58775862d 100644
--- a/testing/open-vm-tools/APKBUILD
+++ b/testing/open-vm-tools/APKBUILD
@@ -2,7 +2,7 @@
pkgname=open-vm-tools
pkgver=8.4.2
_pkgsubver=261024
-pkgrel=0
+pkgrel=1
pkgdesc="The Open Virtual Machine Tools are the open source implementation of VMware Tools."
url="http://open-vm-tools.sourceforge.net/"
license="LGPL"
diff --git a/testing/sircbot/APKBUILD b/testing/sircbot/APKBUILD
index 85035fc4f1..4271ac22b2 100644
--- a/testing/sircbot/APKBUILD
+++ b/testing/sircbot/APKBUILD
@@ -1,17 +1,16 @@
-# Contributor:
-# Maintainer:
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=sircbot
-pkgver=0.1
-pkgrel=1
+pkgver=0.2
+pkgrel=0
pkgdesc="Minimalistic IRC bot"
url="http://git.alpinelinux.org/cgit/sircbot/"
license="GPL-2"
pkgusers="sircbot"
pkggroups="sircbot"
depends=
-makedepends=
+makedepends="lua-dev"
install="$pkgname.pre-install"
-subpackages=
+subpackages="lua-sircbot:luamod"
source="http://git.alpinelinux.org/cgit/sircbot/snapshot/sircbot-$pkgver.tar.bz2
sircbot.initd
sircbot.confd
@@ -29,12 +28,18 @@ build() {
package() {
cd "$_builddir"
- install -m755 -D sircbot "$pkgdir"/usr/bin/sircbot
+ make install DESTDIR="$pkgdir" prefix=/usr
install -o sircbot -g sircbot -d "$pkgdir"/var/run/sircbot
install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
}
-md5sums="82e4cb6c7207761301e63c24d73afd2c sircbot-0.1.tar.bz2
+luamod() {
+ pkgdesc="Luamodule for sirbot client"
+ mkdir -p "$subpkgdir"/usr/
+ mv "$pkgdir"/usr/lib "$subpkgdir"/usr/
+}
+
+md5sums="a9d16db48c97ebfa30e1c84f37e70838 sircbot-0.2.tar.bz2
16790493e7ce465fd776dcfadc002a7c sircbot.initd
8443ac189030c7b8beb8e579dc16ebc7 sircbot.confd"
diff --git a/testing/tinc/APKBUILD b/testing/tinc/APKBUILD
new file mode 100644
index 0000000000..1ae15310e4
--- /dev/null
+++ b/testing/tinc/APKBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=tinc
+pkgver=1.0.13
+pkgrel=0
+pkgdesc="tinc is a Virtual Private Network (VPN) daemon"
+url="http://www.tinc-vpn.org/"
+license="GPL-2"
+depends=
+makedepends="zlib-dev lzo-dev openssl-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://www.tinc-vpn.org/packages/tinc-$pkgver.tar.gz
+ tincd.initd
+ tincd.lo.initd
+ tinc.networks"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-jumbograms \
+ --enable-lzo \
+ --enable-zlib
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+
+ mkdir "$pkgdir"/etc/tinc
+ install -m755 -D "$srcdir"/tincd.initd "$pkgdir"/etc/init.d/tincd
+ install -m755 -D "$srcdir"/tincd.lo.initd \
+ "$pkgdir"/etc/init.d/tincd.lo
+ install -m644 -D "$srcdir"/tinc.networks \
+ "$pkgdir"/etc/conf.d/tinc.networks
+}
+
+md5sums="86263994d38c750431efd17e9a91a248 tinc-1.0.13.tar.gz
+89d104d38bab84d6f92d27464e48628d tincd.initd
+96d8778284637fa7790a4c6239a72070 tincd.lo.initd
+475d64d9aa410ec7e91f5b079800abc9 tinc.networks"
diff --git a/testing/tinc/tinc.networks b/testing/tinc/tinc.networks
new file mode 100644
index 0000000000..e1844ce2ba
--- /dev/null
+++ b/testing/tinc/tinc.networks
@@ -0,0 +1,13 @@
+# file: /etc/conf.d/tinc.networks for /etc/init.d/tincd
+
+# In this file you define the tinc networks you want to connect to
+
+# USAGE:
+# you add a network to the init script by defining:
+# NETWORK: your_network_name
+#
+# if you want to connect to multiple VPN's just set them behind each other. e.g.
+# NETWORK: foo
+# NETWORK: bar
+#
+# this would join the network foo and the network bar.
diff --git a/testing/tinc/tincd.initd b/testing/tinc/tincd.initd
new file mode 100644
index 0000000000..452687dfb6
--- /dev/null
+++ b/testing/tinc/tincd.initd
@@ -0,0 +1,64 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/files/tincd,v 1.5 2008/04/01 14:08:45 dragonheart Exp $
+
+opts="reload"
+
+depend() {
+ use logger dns
+ need net
+}
+
+checkconfig() {
+ if ! grep -q '^ *NETWORK:' /etc/conf.d/tinc.networks
+ then
+ eerror "No VPN networks configured in /etc/conf.d/tinc.networks"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting tinc VPN networks"
+ eend 0
+ awk '/^ *NETWORK:/ { print $2 }' /etc/conf.d/tinc.networks | while read TINCNET
+ do
+ if [ ! -f /etc/tinc/"$TINCNET"/tinc.conf ]
+ then
+ eerror "Cannot start network $TINCNET, /etc/tinc/$TINCNET/tinc.conf does not exist !"
+ else
+ ebegin "Starting tinc network $TINCNET"
+ /usr/sbin/tincd --net="$TINCNET" --logfile=/var/log/tinc.$TINCNET.log --pidfile=/var/run/tinc.$TINCNET.pid
+ eend $?
+ fi
+ done
+}
+
+stop() {
+ ebegin "Stopping tinc VPN networks"
+ eend 0
+ awk '/^ *NETWORK:/ { print $2 }' /etc/conf.d/tinc.networks | while read TINCNET
+ do
+ if [ -f /var/run/tinc."$TINCNET".pid ]
+ then
+ ebegin "Stopping tinc network $TINCNET"
+ /usr/sbin/tincd --kill --pidfile=/var/run/tinc."$TINCNET".pid
+ eend $?
+ fi
+ done
+}
+
+reload() {
+ ebegin "Reloading configuration for tinc VPN networks"
+ eend 0
+ awk '/^ *NETWORK:/ { print $2 }' /etc/conf.d/tinc.networks | while read TINCNET
+ do
+ if [ -f /var/run/tinc."$TINCNET".pid ]
+ then
+ ebegin "Reloading tinc network $TINCNET"
+ /usr/sbin/tincd --kill HUP --pidfile=/var/run/tinc."$TINCNET".pid
+ eend $?
+ fi
+ done
+}
diff --git a/testing/tinc/tincd.lo.initd b/testing/tinc/tincd.lo.initd
new file mode 100644
index 0000000000..79c185b381
--- /dev/null
+++ b/testing/tinc/tincd.lo.initd
@@ -0,0 +1,46 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/files/tincd.lo,v 1.1 2010/07/18 10:04:56 dragonheart Exp $
+
+opts="reload"
+
+depend()
+{
+ use logger dns
+ need net
+}
+
+start()
+{
+ TINCNET=${RC_SVCNAME#*.}
+ if [ -f /etc/tinc/"$TINCNET"/tinc.conf ] ; then
+ ebegin "Starting tinc network $TINCNET"
+ /usr/sbin/tincd --debug=1 --net="$TINCNET" --logfile=/var/log/tinc.$TINCNET.log --pidfile=/var/run/tinc.$TINCNET.pid
+ eend $?
+ else
+ eerror "Cannot start network $TINCNET, /etc/tinc/$TINCNET/tinc.conf does not exist !"
+ fi
+}
+
+stop()
+{
+ TINCNET=${RC_SVCNAME#*.}
+ if [ -f /var/run/tinc."$TINCNET".pid ] ; then
+ ebegin "Stopping tinc network $TINCNET"
+ /usr/sbin/tincd --kill --pidfile=/var/run/tinc."$TINCNET".pid
+ eend $?
+ else
+ eerror "Cannot start network $TINCNET, /etc/tinc/$TINCNET/tinc.conf does not exist !"
+ fi
+}
+
+reload()
+{
+ TINCNET=${RC_SVCNAME#*.}
+ if [ -f /var/run/tinc."$TINCNET".pid ] ; then
+ ebegin "Reloading configuration for tinc network $TINCNET"
+ /usr/sbin/tincd --kill HUP --pidfile=/var/run/tinc."$TINCNET".pid
+ eend $?
+ fi
+}