aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/py-passlib/APKBUILD19
-rw-r--r--testing/py-passlib/skip-bsdi_crypt-test.patch12
2 files changed, 26 insertions, 5 deletions
diff --git a/testing/py-passlib/APKBUILD b/testing/py-passlib/APKBUILD
index d957534df0..2f699fc47c 100644
--- a/testing/py-passlib/APKBUILD
+++ b/testing/py-passlib/APKBUILD
@@ -3,20 +3,23 @@
pkgname=py-passlib
_pkgname=passlib
pkgver=1.7.1
-pkgrel=0
+pkgrel=1
pkgdesc="A python hashing library for over 30 schemes"
url="https://pypi.python.org/pypi/passlib"
arch="noarch"
license="BSD"
+checkdepends="py-nose"
makedepends="python2-dev python3-dev py-setuptools"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ skip-bsdi_crypt-test.patch
+ "
builddir="$srcdir"/passlib-$pkgver
build() {
cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python2 setup.py build
+ python3 setup.py build
}
package() {
@@ -42,4 +45,10 @@ _py() {
$python setup.py install --prefix=/usr --root="$subpkgdir"
}
-sha512sums="3d5f069cd4e44e5e87cdabc46845acbdd6c1eeedb7ce1f611aebee87b0f7af19009b6a47a10ec555fd84260b9f5c933c6429e325d30326de3869f05031674168 passlib-1.7.1.tar.gz"
+check() {
+ cd "$builddir"
+ nosetests --tests passlib.tests
+}
+
+sha512sums="3d5f069cd4e44e5e87cdabc46845acbdd6c1eeedb7ce1f611aebee87b0f7af19009b6a47a10ec555fd84260b9f5c933c6429e325d30326de3869f05031674168 passlib-1.7.1.tar.gz
+9cc34569c963897647f43153753ec81f40eac528f638953e52552c72f31d4a5427af34ce257520de5180e76a0e60bf06eba43459c28b469a43b44e0feecfaf76 skip-bsdi_crypt-test.patch"
diff --git a/testing/py-passlib/skip-bsdi_crypt-test.patch b/testing/py-passlib/skip-bsdi_crypt-test.patch
new file mode 100644
index 0000000000..60d9cf0d1e
--- /dev/null
+++ b/testing/py-passlib/skip-bsdi_crypt-test.patch
@@ -0,0 +1,12 @@
+--- passlib-1.7.1/passlib/tests/utils.py
++++ passlib-1.7.1/passlib/tests/utils.py.new
+@@ -3171,8 +3171,7 @@
+ self.fail("expected %r platform would have native support "
+ "for %r" % (platform, self.handler.name))
+ else:
+- self.fail("did not expect %r platform would have native support "
+- "for %r" % (platform, self.handler.name))
++ raise self.skipTest("varied support on %r platform" % platform)
+
+ #===================================================================
+ # fuzzy verified support -- add new verified that uses os crypt()