aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/firefox/APKBUILD5
-rw-r--r--testing/xulrunner/APKBUILD4
2 files changed, 7 insertions, 2 deletions
diff --git a/testing/firefox/APKBUILD b/testing/firefox/APKBUILD
index 3c83c8c101..4df43df6a7 100644
--- a/testing/firefox/APKBUILD
+++ b/testing/firefox/APKBUILD
@@ -4,7 +4,7 @@ pkgname=firefox
pkgver=10.0
_pkgver=$pkgver
_xulver=10.0
-pkgrel=0
+pkgrel=1
pkgdesc="firefox web browser"
url="http://www.firefox.com"
arch="all"
@@ -52,6 +52,8 @@ source="http://releases.mozilla.org/pub/mozilla.org/${pkgname}/releases/${pkgver
firefox.desktop
firefox-safe.desktop"
+options="!strip"
+
_builddir="${srcdir}/mozilla-release"
_mozappdir=/usr/lib/firefox-$pkgver
@@ -68,6 +70,7 @@ prepare() {
cp "${srcdir}/mozconfig" .mozconfig
echo "ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)" >> .mozconfig
+ echo "ac_add_options --enable-debug-symbols" >> .mozconfig
}
build() {
diff --git a/testing/xulrunner/APKBUILD b/testing/xulrunner/APKBUILD
index 920b3256c8..24e8f39297 100644
--- a/testing/xulrunner/APKBUILD
+++ b/testing/xulrunner/APKBUILD
@@ -3,7 +3,7 @@
pkgname=xulrunner
pkgver=10.0
_ffoxver=10.0
-pkgrel=0
+pkgrel=1
pkgdesc="runtime environment for xul-based applications"
url="http://developer.mozilla.org/en/XULRunner"
arch="all"
@@ -40,6 +40,7 @@ makedepends="$depends_dev
automake
libtool"
install=""
+options="!strip"
subpackages="$pkgname-dev"
# http://releases.mozilla.org/pub/mozilla.org/xulrunner/releases/${pkgver}/source/${pkgname}-${pkgver}.source.tar.bz2
source="http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${_ffoxver}/source/firefox-${_ffoxver}.source.tar.bz2
@@ -64,6 +65,7 @@ prepare() {
done
cp "${srcdir}/mozconfig" .mozconfig
+ echo "ac_add_options --enable-debug-symbols" >> .mozconfig
}
build() {