aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/nqp/APKBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/testing/nqp/APKBUILD b/testing/nqp/APKBUILD
index 256c0c0148..d1e15514ee 100644
--- a/testing/nqp/APKBUILD
+++ b/testing/nqp/APKBUILD
@@ -5,7 +5,7 @@ pkgver=2018.04
pkgrel=0
pkgdesc="Not Quite Perl"
url="https://github.com/perl6/nqp"
-arch="all"
+arch="all !x86"
options="!archcheck" # Arch dependencies are embedded
license="Artistic-2.0"
depends="moarvm"
@@ -15,8 +15,10 @@ subpackages="$pkgname-doc"
source="${pkgname}-${pkgver}.tar.gz::https://github.com/perl6/nqp/archive/${pkgver}.tar.gz"
builddir="$srcdir"/"$pkgname"-"$pkgver"
-# some tests fail on armhf, need to investigate more
-[ "$CARCH" = "armhf" ] && options="$options !check"
+# FIXME: some tests fail on armhf and x86, need to investigate more
+case "$CARCH" in
+ armhf | x86) options="$options !check";;
+esac
build() {
cd "$builddir"