aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/patchwork/0001-use-webapps-dir-structure.patch45
-rw-r--r--testing/patchwork/APKBUILD14
-rw-r--r--testing/patchwork/patchwork.wsgi.conf21
3 files changed, 52 insertions, 28 deletions
diff --git a/testing/patchwork/0001-use-webapps-dir-structure.patch b/testing/patchwork/0001-use-webapps-dir-structure.patch
new file mode 100644
index 0000000000..723737f9de
--- /dev/null
+++ b/testing/patchwork/0001-use-webapps-dir-structure.patch
@@ -0,0 +1,45 @@
+From 19538be6d68f463ef3711054da4c68b32325e63b Mon Sep 17 00:00:00 2001
+From: Carlo Landmeter <clandmeter@gmail.com>
+Date: Wed, 22 Apr 2015 14:30:41 +0200
+Subject: [PATCH] use webapps dir structure
+
+---
+ lib/apache2/patchwork.wsgi.conf | 16 ++++++++--------
+ 1 file changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/lib/apache2/patchwork.wsgi.conf b/lib/apache2/patchwork.wsgi.conf
+index 3756e5a..0be4174 100644
+--- a/lib/apache2/patchwork.wsgi.conf
++++ b/lib/apache2/patchwork.wsgi.conf
+@@ -1,20 +1,20 @@
+ <IfModule mod_alias.c>
+- Alias /images/ "/srv/patchwork/htdocs/images/"
+- Alias /css/ "/srv/patchwork/htdocs/css/"
+- Alias /js/ "/srv/patchwork/htdocs/js/"
+- Alias /robots.txt "/srv/patchwork/htdocs/robots.txt"
+- <Directory "/srv/patchwork/htdocs">
++ Alias /images/ "/usr/share/webapps/patchwork/htdocs/images/"
++ Alias /css/ "/usr/share/webapps/patchwork/htdocs/css/"
++ Alias /js/ "/usr/share/webapps/patchwork/htdocs/js/"
++ Alias /robots.txt "/usr/share/webapps/patchwork/htdocs/robots.txt"
++ <Directory "/usr/share/webapps/patchwork/htdocs">
+ Order allow,deny
+ Allow from all
+ </Directory>
+
+- Alias /media/ "/usr/share/python-support/python-django/django/contrib/admin/media/"
++ Alias /static/admin/ "/usr/lib/python2.7/site-packages/django/contrib/admin/static/admin/"
+
+- <Directory "/usr/share/python-support/python-django/django/contrib/admin/media/">
++ <Directory "/usr/lib/python2.7/site-packages/django/contrib/admin/static/admin/">
+ Order allow,deny
+ Allow from all
+ </Directory>
+ </IfModule>
+
+-WSGIScriptAlias / "/srv/patchwork/lib/apache2/patchwork.wsgi"
++WSGIScriptAlias / "/usr/share/webapps/patchwork/lib/apache2/patchwork.wsgi"
+ WSGIPassAuthorization On
+--
+2.3.5
+
diff --git a/testing/patchwork/APKBUILD b/testing/patchwork/APKBUILD
index 82f681e881..8e1b695068 100644
--- a/testing/patchwork/APKBUILD
+++ b/testing/patchwork/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=patchwork
pkgver=0_git20150420
-pkgrel=2
+pkgrel=3
pkgdesc="Web-based patch tracking system "
url="http://jk.ozlabs.org/projects/patchwork/"
arch="noarch"
@@ -11,10 +11,10 @@ depends="py-django1.5 py-django-registration git"
depends_dev=""
makedepends="$depends_dev"
install=""
-subpackages="$pkgname-doc $pkgname-apache2-wsgi:apache2_wsgi $pkgname-mysql 4pkgname-postgresql"
+subpackages="$pkgname-doc $pkgname-apache2-wsgi:apache2_wsgi $pkgname-mysql $pkgname-postgresql"
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz
0001-support-busybox-readlink.patch
- patchwork.wsgi.conf"
+ 0001-use-webapps-dir-structure.patch"
giturl="git://ozlabs.org/home/jk/git/patchwork"
disturl="dev.alpinelinux.org:/archive/$pkgname/"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -41,7 +41,7 @@ apache2_wsgi() {
pkgdesc="$pkgname apache2 wsgi support"
depends="apache2 apache2-mod-wsgi"
install_if="apache2-mod-wsgi"
- install -Dm644 "$srcdir"/patchwork.wsgi.conf \
+ install -Dm644 "$pkgdir"/usr/share/webapps/patchwork/lib/apache2/patchwork.wsgi.conf \
"$subpkgdir"/etc/apache2/conf.d/patchwork.wsgi.conf || return 1
}
@@ -59,10 +59,10 @@ postgresql() {
md5sums="d327c8ca2f219f597855afadaa520c1d patchwork-0_git20150420.tar.gz
597e39e9742fa8352b3d34f59f8d404e 0001-support-busybox-readlink.patch
-17ca0f41552a80e2a1110a181b78c41b patchwork.wsgi.conf"
+629ebd3fa8ed122b319a73161367c9c1 0001-use-webapps-dir-structure.patch"
sha256sums="769f6839f4e25321ecedaf8e7561e1a5e71e2fdb942c33aefb0798f651ed0914 patchwork-0_git20150420.tar.gz
b87b6ab985e30e75d641d31cfae76420eb3dc5e90b7484f217dd92454e3495af 0001-support-busybox-readlink.patch
-e7b63c9cd749f3d055ddb6d32e95e04fd34891992bb97bac86385fdbb87f252a patchwork.wsgi.conf"
+6266599432e20b2c638023417346d94840e4fbaaedd1899895904315376ad50f 0001-use-webapps-dir-structure.patch"
sha512sums="5e0f93afa3d9afbb97a7e44e355f0f6fae87e77ea8a7d960637984f8f33751a0acd937efc583e6ec6405ca3ff7eb86d100b8ae66e565961afac572fd72587a25 patchwork-0_git20150420.tar.gz
09fc0d88ce766bce53a0789276e6ad3e52049771e3945ae6a9e6b61cc706f5a44d398de5ae23055b2d205fd3844b84fca538617142e194c5ca149263b9afa0bb 0001-support-busybox-readlink.patch
-fc63ad24751d7c7e8beabc7a84034b2086c251be3dfcda26c02aefdd5b369bcda32962f80ddf2d9fa775d625d5d33fde04e2c80485fc9aa3cae886bf363e15f1 patchwork.wsgi.conf"
+429df7faef59701d3754b001a0834fe4a91c13f20a2f50d407d21b145f167ce241fea046e8c251b1993c2e8b7e0aeb29bf69227446ca2236db0e5dd576f38477 0001-use-webapps-dir-structure.patch"
diff --git a/testing/patchwork/patchwork.wsgi.conf b/testing/patchwork/patchwork.wsgi.conf
deleted file mode 100644
index 2efd67460e..0000000000
--- a/testing/patchwork/patchwork.wsgi.conf
+++ /dev/null
@@ -1,21 +0,0 @@
-<IfModule mod_alias.c>
- Alias /images/ "/usr/share/webapps/patchwork/htdocs/images/"
- Alias /css/ "/usr/share/webapps/patchwork/htdocs/css/"
- Alias /js/ "/usr/share/webapps/patchwork/htdocs/js/"
- Alias /robots.txt "/usr/share/webapps/patchwork/htdocs/robots.txt"
- <Directory "/usr/share/webapps/patchwork/htdocs">
- Order allow,deny
- Allow from all
- </Directory>
-
- Alias /static/admin/ "/usr/lib/python2.7/site-packages/django/contrib/admin/static/admin/"
-
- <Directory "/usr/lib/python2.7/site-packages/django/contrib/admin/static/admin/">
- Order allow,deny
- Allow from all
- </Directory>
-</IfModule>
-
-WSGIScriptAlias / "/usr/share/webapps/patchwork/lib/apache2/patchwork.wsgi"
-WSGIPassAuthorization On
-