aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/py-backcall/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/py-backcall/APKBUILD b/testing/py-backcall/APKBUILD
new file mode 100644
index 0000000000..eca5d7396d
--- /dev/null
+++ b/testing/py-backcall/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
+# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
+pkgname=py-backcall
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="Backwards compatible callback APIs"
+url="https://github.com/takluyver/backcall"
+arch="noarch"
+license="BSD-3-Clause"
+makedepends="python2-dev python3-dev"
+options="!check" # pytest broken on alpine
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/b/backcall/backcall-$pkgver.tar.gz"
+builddir="$srcdir/${pkgname#py-}-$pkgver"
+
+build() {
+ cd "$builddir"
+ python setup.py build
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="359c483fbc8998fc2420daee2a6af7566c47fb03f64e465aa226589a2f98a4b219ab5e5b90e5f677087827a1ac658c02ec3062e9ffe9ac1ebfd9db3bb40339cd backcall-0.1.0.tar.gz"