aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/bluez5/APKBUILD75
-rw-r--r--testing/bluez5/bluetooth.initd11
-rw-r--r--testing/bluez5/rfcomm.confd5
-rw-r--r--testing/bluez5/rfcomm.initd27
-rw-r--r--testing/libreswan/APKBUILD8
5 files changed, 122 insertions, 4 deletions
diff --git a/testing/bluez5/APKBUILD b/testing/bluez5/APKBUILD
new file mode 100644
index 0000000000..1f072ae77a
--- /dev/null
+++ b/testing/bluez5/APKBUILD
@@ -0,0 +1,75 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=bluez5
+pkgver=5.7
+pkgrel=0
+pkgdesc="Tools for the Bluetooth protocol stack"
+url="http://www.bluez.org/"
+arch="all"
+license="GPL2"
+depends="consolekit dbus"
+replaces="udev"
+makedepends="dbus-dev libusb-compat-dev udev-dev
+ libical-dev readline-dev glib-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-cups
+ $pkgname-hid2hci"
+source="http://www.kernel.org/pub/linux/bluetooth/bluez-$pkgver.tar.bz2
+ bluetooth.initd
+ rfcomm.initd
+ rfcomm.confd
+ "
+
+_builddir="$srcdir"/bluez-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libexecdir=/usr/lib \
+ --mandir=/usr/share/man \
+ --disable-systemd \
+ --enable-library \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir" || return 1
+ rm "$pkgdir"/usr/lib/*.la || return 1
+ install -Dm755 "$srcdir"/bluetooth.initd "$pkgdir"/etc/init.d/bluetooth
+ install -Dm755 "$srcdir"/rfcomm.initd "$pkgdir"/etc/init.d/rfcomm
+ install -Dm644 "$srcdir"/rfcomm.confd "$pkgdir"/etc/conf.d/rfcomm
+ install -Dm755 test/simple-agent "$pkgdir"/usr/bin/bluez-simple-agent
+}
+
+libs() {
+ pkgdesc="Libraries for Bluetooth protocol stack"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libbluetooth.so.* "$subpkgdir"/usr/lib/
+}
+
+cups() {
+ pkgdesc="Bluez backend for CUPS"
+ mkdir -p "$subpkgdir"/usr/lib/
+ mv "$pkgdir"/usr/lib/cups "$subpkgdir"/usr/lib/
+}
+
+hid2hci() {
+ pkgdesc="Put HID proxying bluetooth HCI's into HCI mode"
+ replaces="bluez"
+ mkdir -p "$subpkgdir"
+ mv "$pkgdir"/lib "$subpkgdir"/
+}
+
+md5sums="eb883ce61753bd3f300a531bcc2af49e bluez-5.7.tar.bz2
+833746cfe1c4f8188a8cd03f157b4a93 bluetooth.initd
+7672edb8e33c4495ee9febb9864feb10 rfcomm.initd
+7f4bb093adb0f519c621f2ea68712f35 rfcomm.confd"
+sha256sums="8db8b024e3edd897b30290134ad02920ad42f6cb0f93fcd6f7057672a4e28f7d bluez-5.7.tar.bz2
+b637eeb3ddc4143fac2510ff2f3f192f8d853d421d495f063953050838bc13a2 bluetooth.initd
+4430703a9bec9a9482416b2d24aa47492264768a0b61356b361bbc8b1229a83e rfcomm.initd
+672498957049fd301f9c9c1dc9fa49430e5e6d3c3f1f3cdce80df3af7d425d08 rfcomm.confd"
+sha512sums="edce3504708ad5e5717941c668bc285c17c5ccc5dea82881d2e9d25fe266f98294dacf0e79d4ca4a68ffb204c328fef75d4cdab1b4f4750156ccdc5b9662e2a3 bluez-5.7.tar.bz2
+69b4834b07124eef32712a92d20b2ac865cfb48c43ec3895edb270b258189013a82758c3fc76faa12735ba8d04b1e77f95cf1322b1c7332a04c3d9621376936f bluetooth.initd
+8f14b4e05c9ecaf4586ed2fdc2d2519de6b613de62ae5c95508baa682630f3112c5b6db6850f76679afc49e06f2ad035d148fa30b9b980747b6fb423f7bebe88 rfcomm.initd
+a70aa0dbbabe7e29ee81540a6f98bf191a850da55a28f678975635caf34b363cf4d461a801b3484120ee28fdd21240bd456a4f5d706262700924bd2e9a0972fb rfcomm.confd"
diff --git a/testing/bluez5/bluetooth.initd b/testing/bluez5/bluetooth.initd
new file mode 100644
index 0000000000..23426b7c89
--- /dev/null
+++ b/testing/bluez5/bluetooth.initd
@@ -0,0 +1,11 @@
+#!/sbin/runscript
+
+name="Bluetooth"
+command="/usr/lib/bluetooth/bluetoothd"
+
+
+depend() {
+ after coldplug
+ need dbus localmount
+}
+
diff --git a/testing/bluez5/rfcomm.confd b/testing/bluez5/rfcomm.confd
new file mode 100644
index 0000000000..d87acdb282
--- /dev/null
+++ b/testing/bluez5/rfcomm.confd
@@ -0,0 +1,5 @@
+# Bind rfcomm devices (allowed values are "true" and "false")
+RFCOMM_ENABLE=true
+
+# Config file for rfcomm
+RFCOMM_CONFIG="/etc/bluetooth/rfcomm.conf"
diff --git a/testing/bluez5/rfcomm.initd b/testing/bluez5/rfcomm.initd
new file mode 100644
index 0000000000..d3b819e1ab
--- /dev/null
+++ b/testing/bluez5/rfcomm.initd
@@ -0,0 +1,27 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez/files/rfcomm-init.d,v 1.1 2011/12/31 21:09:18 pacho Exp $
+
+depend() {
+ after coldplug
+ need dbus localmount hostname
+}
+
+start() {
+ if [ "${RFCOMM_ENABLE}" = "true" -a -x /usr/bin/rfcomm ]; then
+ if [ -f "${RFCOMM_CONFIG}" ]; then
+ ebegin "Starting rfcomm"
+ /usr/bin/rfcomm -f "${RFCOMM_CONFIG}" bind all
+ eend $?
+ else
+ ewarn "Not enabling rfcomm because RFCOMM_CONFIG does not exists"
+ fi
+ fi
+}
+
+stop() {
+ ebegin "Shutting down rfcomm"
+ /usr/bin/rfcomm release all
+ eend $?
+}
diff --git a/testing/libreswan/APKBUILD b/testing/libreswan/APKBUILD
index ba2a5b93a8..c069ac8f55 100644
--- a/testing/libreswan/APKBUILD
+++ b/testing/libreswan/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libreswan
-pkgver=3.3
+pkgver=3.5
pkgrel=0
pkgdesc='IPsec implementation for Linux'
url='https://libreswan.org/'
@@ -32,9 +32,9 @@ package() {
|| return 1
}
-md5sums="a3e8562dfa1a7f4384e0e66a26acec52 libreswan-3.3.tar.gz
+md5sums="7dbf9dbd79836b567e3231006eed3109 libreswan-3.5.tar.gz
014d8187d22a348a04dd2fdba4fc0d46 ipsec.initd"
-sha256sums="ed30825d0d9c5742d53be1c6d251023ac23c0cccbabb4bd2714447985f05232d libreswan-3.3.tar.gz
+sha256sums="0115f84c0171908b5c9b8b7d59aba42933bd50f2cb88483f752f72e16f2fd880 libreswan-3.5.tar.gz
f21668846fdf6d01a7d92672adf0a5dda63f827b317ab0253a7c627968656d8f ipsec.initd"
-sha512sums="407ca3088dc77d651183fe1dd4e8c259d1c39c500137c5053c7a0dae9435d5b432e22cff7e84b377344da016ebe0d9e2ed68565fe6b5837f9ecf79b0b6a6e994 libreswan-3.3.tar.gz
+sha512sums="bed9c56118b141e2054c7eead027df4aabbd2ff996d329e4c59411d418e70f35f329142a5ceb0f047cd2dafea2f45d5e0933f57c84b09387990b3d364ae81462 libreswan-3.5.tar.gz
c245b20e1ea8bd1a615f467e72ccbb3df7b63a60d1fcdb7b485a791377a0adfa75942ed73a6fb1c792eca472c92d3d524e33ba0594467738aac3aaa9123778b2 ipsec.initd"