aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/libtommath/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/libtommath/APKBUILD b/testing/libtommath/APKBUILD
new file mode 100644
index 0000000000..3430f27c62
--- /dev/null
+++ b/testing/libtommath/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=libtommath
+pkgver=1.2.0
+pkgrel=0
+pkgdesc="Portable number theoretic multi-precision integer library"
+url="https://www.libtom.net/LibTomMath/"
+arch="all"
+license="custom:LibTom"
+makedepends="libtool"
+subpackages="$pkgname-static $pkgname-dev"
+source="https://github.com/libtom/libtommath/releases/download/v$pkgver/ltm-$pkgver.tar.xz"
+
+build() {
+ make -f makefile.shared IGNORE_SPEED=1
+ make
+}
+
+package() {
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+ make -f makefile.shared PREFIX=/usr DESTDIR="$pkgdir" install
+}
+
+sha512sums="6f9ccd0691831f07f86ddc81cb6145504b3d5da66dd3e92312c64cce0ea986fa4e08ba65ca8991aaebe56702c2d7c15f309696785b813dffb4c112a4ad04b203 ltm-1.2.0.tar.xz"